Page MenuHomePhabricator

Civi Upgrade UI issue: Quick Search doesn't work consistently or well
Closed, ResolvedPublic2 Story Points

Description

I'm using Civi for the first time since the upgrade and the search bar radio buttons are functioning oddly. I can't consistently select radio buttons....but the search functionality in the bar itself does appear to work. Attached is a pic where I've clicked on the Last Name radio button and that's showing in the search bar, but the radio button still shows Street Address as the selection. As far as I can tell, the functionality is fine, it's just the UI that seems wonky.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 11 2019, 3:04 PM
CaitVirtue added a comment.EditedFeb 11 2019, 5:37 PM

I've found some additional search problems....

When I try to search for myself by last name, i don't get any results even though I have two records in the system. :-(

Leanne's got issues too....i think it's safe to say that the Quick Search bar is generally misbehaving...

CaitVirtue renamed this task from Civi Upgrade UI issue: Can't select radio buttons in Civi Search to Civi Upgrade UI issue: Quick Search doesn't work consistently or well.Feb 11 2019, 6:10 PM
Restricted Application added subscribers: Pcoombe, Liuxinyu970226, TerraCodes. · View Herald TranscriptFeb 11 2019, 6:26 PM
mepps added a subscriber: mepps.Feb 11 2019, 8:08 PM

Both issues appear to be caused by the js in the selector. Unfortunately I'm trying to repair my local civi install so I can't debug. In my testing, it could find me, but if I selected another search option then tried to go back to Name, it suddenly couldn't find me.

I just disabled the extension that makes the menu responsive now & it seems to have fixed it for now -- I'll keep digging but let me know how it seems

I was able to replicate this off our site - I have logged upstream - expect I'll get a fix from Coleman fairly quickly - in the meantime I doubt anyone will miss the fact our menu could be responsive but isn't yet...

https://github.com/aydun/uk.squiffle.kam/issues/45

Everything seems to have been fixed, with the exception of the Last Name search. It still returns no results even when it should. @LeanneS - are you having the same issue?

The name search returned results so it appears to be working for me now.

It turns out the issue was that you needed to click on the word not the circle - anyway once we have a fix for that I'll re-enable the responsive menu bar

I think so....we should probably send a note to Civi users that the Last Name search in the Quick Search field does not work, and if you want to search by last name, you should just use the Name search. I haven't tested the First Name Search.

@CaitVirtue is it still not working for you? It works for me...

Ejegg added a subscriber: Ejegg.Feb 14 2019, 2:21 PM

First and Last Name search works for me too.

Eileenmcnaughton closed this task as Resolved.Feb 19 2019, 9:14 PM

Closing this - a new phab is open relating to ongoing issue for @CaitVirtue

Eileenmcnaughton set the point value for this task to 2.Feb 19 2019, 9:14 PM