Page MenuHomePhabricator

labtestweb2001: Fatal error: unknown class AuthPlugin in /srv/mediawiki/php-1.33.0-wmf.20/extensions/LdapAuthentication/LdapAuthenticationPlugin.php on line 21
Closed, ResolvedPublic

Description

Error

_id: AWlO93eRrQwEXb5eTTfL

message
Fatal error: unknown class AuthPlugin in /srv/mediawiki/php-1.33.0-wmf.20/extensions/LdapAuthentication/LdapAuthenticationPlugin.php on line 21
trace

Impact

Notes

I guess wikitech users on labtestweb can no more authenticate/login :/

Event Timeline

hashar created this task.Mar 5 2019, 6:05 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 5 2019, 6:05 PM
hashar triaged this task as Unbreak Now! priority.Mar 5 2019, 6:07 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptMar 5 2019, 6:07 PM

Change 494518 had a related patch set uploaded (by Hashar; owner: Hashar):
[mediawiki/core@master] Revert "Drop AuthPlugin and related code, deprecated in 1.27"

https://gerrit.wikimedia.org/r/494518

Oh, damn, missed one.

Change 494525 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/LdapAuthentication@master] Follow-up 2a9d1c27: Stop referring to the now-killed AuthPlugin class

https://gerrit.wikimedia.org/r/494525

Change 494518 abandoned by Hashar:
Revert "Drop AuthPlugin and related code, deprecated in 1.27"

Reason:
In favor of the hotfix https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/LdapAuthentication/ /494525/

https://gerrit.wikimedia.org/r/494518

Change 494537 had a related patch set uploaded (by Hashar; owner: Jforrester):
[mediawiki/extensions/LdapAuthentication@wmf/1.33.0-wmf.20] Follow-up 2a9d1c27: Stop referring to the now-killed AuthPlugin class

https://gerrit.wikimedia.org/r/494537

That is CI fault to not have caught it (mediawiki/core changes do not run with LdapAuthentication :D ).

Change 494537 merged by jenkins-bot:
[mediawiki/extensions/LdapAuthentication@wmf/1.33.0-wmf.20] Follow-up 2a9d1c27: Stop referring to the now-killed AuthPlugin class

https://gerrit.wikimedia.org/r/494537

Change 494525 merged by jenkins-bot:
[mediawiki/extensions/LdapAuthentication@master] Follow-up 2a9d1c27: Stop referring to the now-killed AuthPlugin class

https://gerrit.wikimedia.org/r/494525

Mentioned in SAL (#wikimedia-operations) [2019-03-05T19:56:05Z] <hashar@deploy1001> Synchronized php-1.33.0-wmf.20/extensions/LdapAuthentication/: Stop referring to the now-killed AuthPlugin class - T217692 (duration: 00m 57s)

hashar added a comment.Mar 5 2019, 8:00 PM

I have no idea how to test labstestwiki :/

bd808 added a subscriber: bd808.Mar 5 2019, 8:19 PM

I just tried to login there and it failed with this fatal message:

PHP fatal error:
Call to undefined method LdapAuthenticationPlugin::getUserInstance()

Change 494605 had a related patch set uploaded (by BryanDavis; owner: Bryan Davis):
[mediawiki/extensions/LdapAuthentication@master] Replace removed AuthPlugin::getUserInstance

https://gerrit.wikimedia.org/r/494605

I will most probably revert the patch from mediawiki/core so we get time to polish up a migration patch for the LdapAuthentication extension.

Change 494605 abandoned by BryanDavis:
Replace removed AuthPlugin methods

Reason:
See Brad's patch at Icb7e468ca37f9185cf6d1b353a7fbb499c0103ad

https://gerrit.wikimedia.org/r/494605

bd808 added a subscriber: Anomie.Mar 6 2019, 5:45 PM

The patch from @Anomie at https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/LdapAuthentication/+/494719/ that I just merged looks like it will fix all of the dangling issues. Would need a backport to unblock the train.

Mentioned in SAL (#wikimedia-operations) [2019-03-06T19:51:36Z] <hashar@deploy1001> Synchronized php-1.33.0-wmf.20/extensions/LdapAuthentication/LdapPrimaryAuthenticationProvider.php: Remove calls to no-longer-imeplemented methods after I2eeaeed1 - T217692 (duration: 00m 58s)

hashar added a comment.Mar 6 2019, 8:32 PM

1.33.0-wmf.20 is hotfixed (thank you!). We have:

"labswiki": "php-1.33.0-wmf.19",
"labtestwiki": "php-1.33.0-wmf.20",

@bd808 can you confirm the labtestwiki works as expected? That would build confidence to promote the branch to all wiki s(including labswiki). Thank you;)

bd808 added a comment.Mar 6 2019, 8:52 PM

1.33.0-wmf.20 is hotfixed (thank you!). We have:

"labswiki": "php-1.33.0-wmf.19",
"labtestwiki": "php-1.33.0-wmf.20",

@bd808 can you confirm the labtestwiki works as expected? That would build confidence to promote the branch to all wiki s(including labswiki). Thank you;)

The fatals from early in the login process are gone. Apparently my account there has a different password than my password manager remembers, so getting a full verification is blocked for me at the moment. Password recovery is blocked for unrelated reasons (r/o db setup there right now.)

We could live test quickly on wikitech I suppose? A potential short login outage there is a manageable risk.

hashar added a comment.Mar 6 2019, 9:02 PM

We could live test quickly on wikitech I suppose? A potential short login outage there is a manageable risk.

Yes sounds doable given the context (probably hard to set up a test environment for LdapAuthentication, though I haven't looked at it / I am not familiar with LDAP).

bd808 added a comment.Mar 6 2019, 9:14 PM

We could live test quickly on wikitech I suppose? A potential short login outage there is a manageable risk.

Yes sounds doable given the context (probably hard to set up a test environment for LdapAuthentication, though I haven't looked at it / I am not familiar with LDAP).

I have verified that login works fine in a local dev environment for LdapAuthentication. There is a MediaWiki-Vagrant role for testing it. What I haven't tested is the OpenStackManager integration with LdapAuthentication.

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/LdapAuthentication/+/494797 is now deployed to wnf.20, and wikitech is running it – can we close this as Resolved?

bd808 closed this task as Resolved.Mar 8 2019, 12:46 AM

Confirmed that logout/login is working as expected on wikitech and that 1.33.0-wmf.20 is the active version.

hashar added a comment.Mar 8 2019, 9:09 AM

Thank you for the patches! :)

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:07 PM