Page MenuHomePhabricator

Call to a member function addJsConfigVars() on a non-object (null)
Closed, ResolvedPublic

Description

Error

Request ID: AWlyJEHYNBo9dX1kEAfZ

message
Call to a member function addJsConfigVars() on a non-object (null)
trace
#0 /srv/mediawiki/php-1.33.0-wmf.21/extensions/MobileFrontend/includes/specials/SpecialMobileOptions.php(63): SpecialMobileOptions->setJsConfigVars()
#1 /srv/mediawiki/php-1.33.0-wmf.21/includes/specialpage/SpecialPage.php(569): SpecialMobileOptions->execute(NULL)
#2 /srv/mediawiki/php-1.33.0-wmf.21/includes/specialpage/SpecialPageFactory.php(558): SpecialPage->run(NULL)
#3 /srv/mediawiki/php-1.33.0-wmf.21/includes/MediaWiki.php(288): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#4 /srv/mediawiki/php-1.33.0-wmf.21/includes/MediaWiki.php(867): MediaWiki->performRequest()
#5 /srv/mediawiki/php-1.33.0-wmf.21/includes/MediaWiki.php(517): MediaWiki->main()
#6 /srv/mediawiki/php-1.33.0-wmf.21/index.php(42): MediaWiki->run()
#7 /srv/mediawiki/w/index.php(3): include(string)
#8 {main}

Impact

Notes

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 12 2019, 1:49 PM
zeljkofilipin triaged this task as Unbreak Now! priority.Mar 12 2019, 1:49 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptMar 12 2019, 1:49 PM

Change 495722 had a related patch set uploaded (by Niedzielski; owner: Stephen Niedzielski):
[mediawiki/extensions/MobileFrontend@master] Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

https://gerrit.wikimedia.org/r/495722

Change 495722 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

https://gerrit.wikimedia.org/r/495722

@Niedzielski @pmiazga @D3r1ck01 looks like the problem is resolved by 495722. This is still blocking the train. Please backport it to wmf.21 and schedule the backport for a SWAT deploy.

Change 495905 had a related patch set uploaded (by Niedzielski; owner: Stephen Niedzielski):
[mediawiki/extensions/MobileFrontend@master] Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

https://gerrit.wikimedia.org/r/495905

@zeljkofilipin, backport will be swatted in about an hour. Sorry for the trouble.

Change 495907 had a related patch set uploaded (by Niedzielski; owner: Stephen Niedzielski):
[mediawiki/extensions/MobileFrontend@wmf/1.33.0-wmf.21] Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

https://gerrit.wikimedia.org/r/495907

Change 495905 abandoned by Niedzielski:
Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

Reason:
@Jforrester, it was indeed intended for wmf/1.33.0-wmf.21. Thank you! Superseded by Ifb89a5c92c5c883b5e0b9c6e533302ff5f683b6e.

https://gerrit.wikimedia.org/r/495905

backport will be swatted in about an hour.

Correction: I confused the upcoming Puppet deployment window for a swat window. Deployment won't be for ~3 hours.

Change 495945 had a related patch set uploaded (by D3r1ck01; owner: Stephen Niedzielski):
[mediawiki/extensions/MobileFrontend@wmf/1.33.0-wmf.21] Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

https://gerrit.wikimedia.org/r/495945

Backport patch created: https://gerrit.wikimedia.org/r/c/mediawiki/extensions/MobileFrontend/+/495945, @Niedzielski, do you want to schedule this for SWAT on wmf.21?

Change 495945 abandoned by D3r1ck01:
Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

Reason:
In favor of Ifb89a5c92c5c883b5e0b9c6e533302ff5f683b6e

https://gerrit.wikimedia.org/r/495945

Change 495907 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@wmf/1.33.0-wmf.21] Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()

https://gerrit.wikimedia.org/r/495907

Mentioned in SAL (#wikimedia-operations) [2019-03-12T23:33:02Z] <thcipriani@deploy1001> Synchronized php-1.33.0-wmf.21/extensions/MobileFrontend/includes/specials/SpecialMobileOptions.php: SWAT: [[gerrit:495907|Fix: undefined locals in SpecialMobileOptions.setJsConfigVars()]] T218098 (duration: 00m 57s)

zeljkofilipin closed this task as Resolved.Mar 13 2019, 11:38 AM
zeljkofilipin claimed this task.
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:07 PM