Page MenuHomePhabricator

Login broken on SVG Translate production tool
Closed, InvalidPublicBug

Description

It's not currently possible to login to the SVG Translate tool in production.

When accessing the log-in action in the SVG translation tool, I get redirected to the OAUth process, but the log-in seems not to take effect: The log-in option is still there (instead of my username or a log-out option, that I would expect when logged in) and the upload to commons option is disabled.

The animation below illustrates the issue:

Event Timeline

Niharika triaged this task as Unbreak Now! priority.Mar 25 2019, 4:55 PM
Niharika created this task.
Restricted Application added a project: Community-Tech. · View Herald TranscriptMar 25 2019, 4:55 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes, Aklapper. · View Herald Transcript

Login works for me on both production and staging. Does it work for you in incognito mode or if you clear your cookies?

Likely unrelated issue: the preview doesn't work for the example https://tools.wmflabs.org/svgtranslate/File:100_Years_War_France_1435-sr.svg

Also, is this is a duplicate of T219179?

jmatazzoni changed the subtype of this task from "Task" to "Bug Report".Mar 25 2019, 9:21 PM
Niharika added a subscriber: Samwilson.

@MusikAnimal Yep. Closed that as a dupe.

CC @Samwilson

MaxSem lowered the priority of this task from Unbreak Now! to High.Mar 25 2019, 9:31 PM
MaxSem added a subscriber: MaxSem.

Login works right now, no errors in the last 4 hours.

Niharika raised the priority of this task from High to Unbreak Now!.Mar 25 2019, 11:34 PM

Moving back to UBN. Still happening for me.

It's not the cause of this issue (which I'm still trying to reproduce properly), but I noticed that the session ID wasn't being regenerated on login so have opened https://github.com/wikimedia/ToolforgeBundle/pull/15

The actual issue here I am thinking might be something similar to T217815 in that maybe the session file isn't being written to the filesystem properly. Although I can't see any incomplete files.

There also seems to be a strange interaction (which again I'm unable to replicate) when the current_filename session variable is set and the user, after logging in, is redirected back to the translate page. Is it possible that this redirection is happening before the bundle's AuthController has finished (or, more likely, before the session has been finalized)? I'm not really sure.

It looks like there's only 4 logged-in users at the moment. We could delete those sessions and what what happens when/if the issue comes back.

It looks like there's only 4 logged-in users at the moment. We could delete those sessions and what what happens when/if the issue comes back.

Sounds fine to me.

MusikAnimal lowered the priority of this task from Unbreak Now! to High.Mar 27 2019, 5:01 PM

From our meeting I'm assuming it's safe to lower from UBN. (People like to see the median age of open UBNs at a minimum :)

Niharika raised the priority of this task from High to Unbreak Now!.Apr 2 2019, 7:16 PM

Sigh. The issue is back. See T219870: Cannot log-in.
Switching this back to UBN status.

Niharika updated the task description. (Show Details)Apr 2 2019, 7:17 PM
Niharika mentioned this in T219870: Cannot log-in.
Niharika added a subscriber: Pginer-WMF.
Niharika lowered the priority of this task from Unbreak Now! to Normal.Apr 2 2019, 11:35 PM
Niharika closed this task as Invalid.Apr 17 2019, 4:05 PM
Niharika moved this task from Ready to Done on the Community-Tech-Sprint board.

Will reopen if this happens again.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptApr 17 2019, 4:05 PM
Niharika moved this task from In progress to Done on the SVG Translate Tool board.Apr 30 2019, 6:47 PM