Page MenuHomePhabricator

New mobile iFrame errors
Closed, ResolvedPublic

Description

#576257 is a Swedish donor, their email address is in cid=7145892. They sent a screenshot for attempts made on Monday:

#577642 is a UK donor using an iPhone SE today, 4/18:
I was going to donate but I entered a different amount. I clicked on the Donate link. I entered my card number and pressed Done then the screen went blank. I tried this a few times in case it was me.

Event Timeline

MBeat33 created this task.Apr 18 2019, 4:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 18 2019, 4:07 PM
MBeat33 added a comment.EditedApr 19 2019, 12:08 PM

#577898: each time I enter my credit card information on iphone 8 (iOS 11.3.1), it wipes the number whenever I’ve filled out the CVV. Then I go back to this blank screen

#577880 the page or rather CC field for Swedish Donors ( and maybe others) crashes when you start filling in the numbers....Have been like this for some weeks.

We're gather as much browser data as we can from these donors, will add more here.

MBeat33 triaged this task as High priority.Apr 19 2019, 3:47 PM
mepps added a subscriber: mepps.Apr 19 2019, 5:04 PM

@MBeat is #577898 a uk or swedish donor?

Their 2011 Ingenico contrib was actually from Denmark, so I'd bet there or Sweden before UK, @mepps

@MBeat33 the UK donor might be getting a different bug. Are more people seeing this in the UK? If so, can you split that out into a new task?

@jrobell do we have any volunteers in Sweden who can retest?

The issue here is that we are getting donations through. If this isn't happening in large amounts it's tough to prioritize and track down.

Ejegg added a subscriber: Ejegg.Apr 19 2019, 5:57 PM

Let's not split this out by country - I'm pretty sure this would all be related to the donation API refactor we put out yesterday, which isn't country-specific.

#577950 is a UK donor from today: "when I try and enter my card details the form goes blank." We're following up for specs.

#577880 sent some more details:

This is how it looks when I have just started, ie it goes blank.
Using an IPhoneX

mepps added a comment.EditedApr 19 2019, 8:18 PM

@Ejegg some of the errors were from Monday though.

Hey All! How can I help with this task? Do you still need volunteers to make a donation in Sweden? Thanks!

Hi @jrobell yes we could still use testing. Thanks!

@MBeat33 any new reports?

One UK donor reported "when I try and enter my card details the form goes blank" on the 19th, but they succeeded on a desktop since then. We have several requests for screenshots/browser details out on possibly-related errors.

#578817
When putting in the credit card number it all disappears.
I've also tried scanning.
On iPhone 6.

Two more examples, both SE:
#578881
Trying to donate via Visa from my IPhone, but when I try to fill in the card number, the "form" disappears.

#578816
I'm trying to put in the credit card number but it disappears.

Following up with both for more information. Both are from yesterday.

Ejegg added a comment.Apr 24 2019, 3:17 PM

OK, if this is happening while the refactor code from last week is still gone, I'm starting to wonder if it's just the known suboptimality of trying to shoe-horn the hosted checkout form into the iframe.

For the iframe, we hide a lot of components of the hosted checkout by setting them to white on white, and use some scrolling tricks to align the remaining card number fields and button in the space available for the frame. If you hit tab a few times, it can scroll those fields out of view. Maybe the iphone's card scan does some virtual tab-hitting?

DStrine moved this task from Triage to Sprint -- on the Fundraising-Backlog board.Apr 29 2019, 7:49 PM
Ejegg added a comment.May 1 2019, 5:48 PM

If the problem does have to do with virtual scrolling, T222290 should fix it

#580856 is a UK donor on 5/1 using an ipad:
Each time l try to donate using my credit card, the area where the card details are inserted disappears. What could be the problem? I have used the same credit card for last year's donation without problems.

We're following up for details.

Ejegg added a comment.May 1 2019, 9:39 PM

@MBeat33, I'm really curious if these people are all using a feature to automatically fill in the fields, like a card stored in the browser or the feature that lets you take a picture of a card.

As mentioned to @MBeat33 I had two testers in Sweden trying to donate from their Iphone. One of them made a donation using AMEX without any issues, the other one got the attached error message when using Safari (but no iframe error)

Given that we also saw a couple of issues in the UK, Peter made three mobile donations earlier this week and didn't experience any issues.

I was using Chrome on Android though. Haven't been able to test iOS.

MBeat33 added a comment.EditedMay 3 2019, 11:28 PM

#582733 5/3 Sweden
When writing the card no the numbers and page disappeared.

#581087 5/3 South Africa
As soon as I tried to type the credit card numbers the category to file disappeared from the screen.

@Ejegg 581087 followed up, and confirmed that they're using Autofill on their iPad, w/Safari.

MBeat33 added a comment.EditedMay 9 2019, 7:16 PM

#584221 5/9 Malaysia
I cannot key-in particulars in the creditcard/debitcard info paragragh...It just disappeared the moment I tried to

#584030 5/9
I tried to donate but the section to enter my card details goes blank every time I start typing the no. in. I’m using mobile.

#584564 5/9 NL
every time I type the first number of my Visa card it disappears

following up for specs

#584030 update
tried using iPhone 6 Version 11.2.6 and Chrome browser, as well as Safari
sent screenshot showing a blank iframe/card entry section

DStrine moved this task from Sprint -- to Triage on the Fundraising-Backlog board.May 14 2019, 6:50 PM
DStrine closed this task as Resolved.May 28 2019, 7:57 PM