Page MenuHomePhabricator

[wmf.15-mobile] Homepage: 'Ask mentor'/'Ask help desk' flashes 'undefined'
Closed, ResolvedPublic

Description

On mobile Homepage click 'Your mentor' or 'Get help with editing'. Then click on 'Cancel' - the word 'undefined' (see the screenshot below) would be briefly displayed:

Note: If a user reloads the page when the overlay displays, the page will be displayed as the following:

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : wmf/1.34.0-wmf.21Homepage: Unbreak question dialogs on mobile
mediawiki/extensions/GrowthExperiments : masterHomepage: Unbreak question dialogs on mobile
mediawiki/extensions/GrowthExperiments : masterHomepage: Restructure mobile overlay handling

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2019, 8:26 PM
Etonkovidova updated the task description. (Show Details)Jul 29 2019, 9:27 PM
JTannerWMF added a subscriber: JTannerWMF.

This is clearly an undesirable bug, so we want to work on it soon.

This bug is very obviously visible if you open e.g. the "ask your mentor" dialog on the mobile site in a desktop browser at full size (without device emulation). The OOUI dialog doesn't cover the whole screen (because the screen isn't small enough to trigger that behavior), and you get this:

Change 527800 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Homepage: Restructure mobile overlay handling

https://gerrit.wikimedia.org/r/527800

Catrope claimed this task.Aug 3 2019, 4:14 AM
Catrope edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
Catrope moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

FWIW, I can't reproduce either of these issues on wmf.17 (testwiki) or beta, but the approach in the patch seems better than what we have now.

FWIW, I can't reproduce either of these issues on wmf.17 (testwiki) or beta, but the approach in the patch seems better than what we have now.

Re-checked wmf.17 - the issue is present in mobile browser (Chrome) emulator (and on iPhone 6Plus, iOS 12).

Krinkle renamed this task from [wmf.15-mobile]Homepage: 'Ask mentor'/'Ask help desk' flashes 'undefined' to [wmf.15-mobile] Homepage: 'Ask mentor'/'Ask help desk' flashes 'undefined' .Aug 26 2019, 7:11 PM
Krinkle awarded a token.

Change 527800 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Homepage: Restructure mobile overlay handling

https://gerrit.wikimedia.org/r/527800

Change 534238 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] Homepage: Unbreak question dialogs on mobile

https://gerrit.wikimedia.org/r/534238

Change 534238 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Homepage: Unbreak question dialogs on mobile

https://gerrit.wikimedia.org/r/534238

Etonkovidova closed this task as Resolved.Sep 4 2019, 4:55 PM

Checked in betalabs - the issue is fixed.

Change 534492 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.21] Homepage: Unbreak question dialogs on mobile

https://gerrit.wikimedia.org/r/534492

Change 534492 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.21] Homepage: Unbreak question dialogs on mobile

https://gerrit.wikimedia.org/r/534492

Mentioned in SAL (#wikimedia-operations) [2019-09-04T17:59:50Z] <jforrester@deploy1001> Synchronized php-1.34.0-wmf.21/extensions/GrowthExperiments/modules/homepage/: T229271 Homepage: Unbreak question dialogs on mobile (duration: 00m 56s)