Page MenuHomePhabricator

Several selectors/experts are broken
Closed, ResolvedPublicBUG REPORT

Description

Several selectors are broken right now. At least you can't:

  • edit language of monolingual text values
  • get the date expert to open up
  • get the unit selector

Initial report:

Steps to Reproduce:

Go to https://www.wikidata.org/wiki/Q66058247

Add a new value to "title", write a bit.

(Also lexemes are affected)

Actual Results:

The language selection drop down does not show up and the "publish" button is greyed

Expected Results:

The language selection drop down should appear and after language selection, the "publish" button should be enabled

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : wmf/1.34.0-wmf.16Define $wgMessagesDirs in WikibaseView PHP entry point
mediawiki/extensions/Wikibase : masterDefine $wgMessagesDirs in WikibaseView PHP entry point
mediawiki/extensions/Wikibase : masterRevert "fix eslint errors in lib after moving submodule files into lib"
mediawiki/extensions/Wikibase : wmf/1.34.0-wmf.16Revert "fix eslint errors in lib after moving submodule files into lib"

Event Timeline

Fnielsen created this task.Aug 1 2019, 6:10 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 1 2019, 6:10 PM

I see the problem also (Safari browser). When you talk about it affecting lexemes, where do you see that? I experimented with adding a form and that seemed fine.

The lexeme has these language fields for word stem.

My browser is Firefox.

Moebeus added a subscriber: Moebeus.Aug 1 2019, 7:10 PM

Can confirm: The problem started around 17:45 GMT +1 and affects all browsers (Firefox, Edge, Chrome and variants).

Now fixed on my end 👍

Yes, fixed at my end too.

Fnielsen closed this task as Resolved.Aug 1 2019, 8:11 PM
Fnielsen claimed this task.
Moebeus added a comment.EditedAug 1 2019, 10:10 PM

It looks like the problem is back, stopped working again just now :(

Fnielsen reopened this task as Open.Aug 1 2019, 11:35 PM

Yes. It is back.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptAug 2 2019, 8:02 AM
Salgo60 added a subscriber: Salgo60.Aug 2 2019, 8:50 AM

Can confirm: The problem started around 17:45 GMT +1 and affects all browsers (Firefox, Edge, Chrome and variants).

17:45 UTC+1 would be about an hour after group1 to wmf.16 (15:40 UTC). It was then moved back to wmf.15 (19:40 UTC) and finally again to wmf.16 (21:23 UTC), which would explain why the error was gone for a bit.

Lydia_Pintscher renamed this task from Not possible to write in language edit fields to Several selectors/experts are broken.Aug 2 2019, 9:40 AM
Lydia_Pintscher removed Fnielsen as the assignee of this task.
Lydia_Pintscher updated the task description. (Show Details)

Change 527500 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/Wikibase@master] Revert "fix eslint errors in lib after moving submodule files into lib"

https://gerrit.wikimedia.org/r/527500

Change 527501 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.16] Revert "fix eslint errors in lib after moving submodule files into lib"

https://gerrit.wikimedia.org/r/527501

Change 527501 merged by Ladsgroup:
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.16] Revert "fix eslint errors in lib after moving submodule files into lib"

https://gerrit.wikimedia.org/r/527501

Some improvement just now :)

I'm working on it. It should be back online now with the change I deployed but with missing i18n messages. I'm on it.

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptAug 2 2019, 11:04 AM

I'm working on it. It should be back online now with the change I deployed but with missing i18n messages. I'm on it.

Thanks a bunch for the fast action!

Works for me now too. Thanks!

Mentioned in SAL (#wikimedia-operations) [2019-08-02T11:34:29Z] <ladsgroup@deploy1001> Started scap: [[phab:T229604|Rebuilding l10n cache]]

Mentioned in SAL (#wikimedia-operations) [2019-08-02T11:39:35Z] <ladsgroup@deploy1001> Finished scap: [[phab:T229604|Rebuilding l10n cache]] (duration: 05m 06s)

Ladsgroup lowered the priority of this task from Unbreak Now! to High.Aug 2 2019, 12:04 PM

After talking to @Lydia_Pintscher sicne people can enter values now, it's good for now but I'm still working on to rebuild the l10n cache.

Change 527500 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Revert "fix eslint errors in lib after moving submodule files into lib"

https://gerrit.wikimedia.org/r/527500

Change 527594 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] Define $wgMessagesDirs in WikibaseView PHP entry point

https://gerrit.wikimedia.org/r/527594

Change 527597 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.16] Define $wgMessagesDirs in WikibaseView PHP entry point

https://gerrit.wikimedia.org/r/527597

Change 527594 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Define $wgMessagesDirs in WikibaseView PHP entry point

https://gerrit.wikimedia.org/r/527594

Change 527597 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@wmf/1.34.0-wmf.16] Define $wgMessagesDirs in WikibaseView PHP entry point

https://gerrit.wikimedia.org/r/527597

Mentioned in SAL (#wikimedia-operations) [2019-08-02T17:25:13Z] <lucaswerkmeister-wmde@deploy1001> Started scap: Fix WikibaseView i18n globals (T229604)

Mentioned in SAL (#wikimedia-operations) [2019-08-02T17:42:04Z] <lucaswerkmeister-wmde@deploy1001> Finished scap: Fix WikibaseView i18n globals (T229604) (duration: 16m 51s)

The issue persisted for ca. 10 minutes after the scap finished, for reasons I don’t understand, but now it does seem to be resolved. Leaving the task open for verification by others.

Mentioned in SAL (#wikimedia-operations) [2019-08-02T18:14:32Z] <Lucas_WMDE> recached all WikibaseView messages in ResourceLoader for T229604, cf. https://w.wiki/6kc