Page MenuHomePhabricator

Error message with HTML entity insertables as params should display the entity as text
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  1. Start translating a message that uses an HTML entity as an insertable.
  2. Don't add the HTML entity in the translation.

Actual Results:

The HTML entity is converted to HTML and displayed, but the insertable shows the text of the HTML entity.

See below,

Expected Results:
Insertables that are HTML entities should be displayed as is, and not transformed.

Details

Related Gerrit Patches:

Event Timeline

abi_ created this task.Sep 3 2019, 9:10 PM

Good catch. The parameter needs additional escaping. Should be simple to fix once you find the place (is it on PHP side or JavaScript side).

Change 546902 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] Display error message with HTML entity insertables properly escaped

https://gerrit.wikimedia.org/r/546902

abi_ added a comment.Oct 31 2019, 12:07 PM

Tested the patch by Niklas locally, and it works well. See screenshot,

Change 546902 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Display error message with HTML entity insertables properly escaped

https://gerrit.wikimedia.org/r/546902

abi_ closed this task as Resolved.Thu, Nov 14, 6:22 PM

Tested this again locally today, and it works fine. Since this does not need any additional configuration after deployment, resolving this task.