Page MenuHomePhabricator

[Regression] Disabling the ability to edit the whole article can make it impossible to edit on mobile in a specific scenario
Closed, ResolvedPublic

Description

We recently disabled the ability to edit the whole article by clicking on the top-most edit pencil. Have found the issue below around this change.

Steps:

  1. Open an article using desktop VE
  2. Go to "Page Settings" menu
  3. Check the option for "Disable the edit links next to each heading on this page"
  4. Now load this article on mobile.

At this point, if a user taps on the only edit pencil that's available (which is the top-most one), it will open just the lede section. I think it's fair to assume that there might be cases where users might not remember changing this setting when they used the desktop version last and wonder about the ways to edit a different section. And if the article does not contain any lede section then it will open a blank page which is more confusing imho.

@ppelberg what would you suggest we do in this case?

Event Timeline

Ryasmeen created this task.Sep 5 2019, 11:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 5 2019, 11:09 PM
  • This is technically a regression in VE, but this has always been the functionality in the mobile wikitext editor
  • The __NOEDITSECTION__ marker which triggers this use very rarely, and usually when the section itself contains just a transclusion of another page, e.g.
== Section 1 ==
{{Included section}}
== Section 2 ==
{{Next included section}}

In these cases there aren't really meaningful section edits to be made, especially on mobile

Possible choices

  1. Ignore/deprioritise
  2. Always show edit pencils on mobile, even if marked as __NOEDITSECTION__
  3. Make the lede edit button edit the whole article when page is marked as __NOEDITSECTION__

I think option 3 is harmless and should be easy to implement, since we already have the ability to open the entire page for editing in mobile editors (it's not normally accessible, but we needed it to handle switching editors while editing a section in some cases).

JTannerWMF moved this task from To Triage to Revisit on the VisualEditor board.Sep 10 2019, 3:36 PM
JTannerWMF added a subscriber: JTannerWMF.

We would like to consider this ticket with the lede edit button T203151 so when we start that work we will return to this ticket

Change 538327 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/MobileFrontend@master] mobile.init/editor: Allow editing whole page with section edit links disabled

https://gerrit.wikimedia.org/r/538327

Change 538327 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] mobile.init/editor: Allow editing whole page with section edit links disabled

https://gerrit.wikimedia.org/r/538327

JTannerWMF added a subscriber: marcella.

This is ready for close out @marcella

marcella closed this task as Resolved.Feb 11 2020, 6:06 PM
marcella awarded a token.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 11 2020, 6:06 PM