Page MenuHomePhabricator

Deploy AMC contextual hooks modal
Closed, ResolvedPublic2 Story Points

Description

Description

In T226069: AMC Outreach - contextual hooks via new Drawer (showing AMC optin drawer within workflows) we built a modal that lets people know about AMC when they perform certain actions. We would now like to turn it on.

User Story

As a mobile editor, I would like to know that advanced mode exists so that I can opt in

Dev notes

Patch at https://gerrit.wikimedia.org/r/#/c/operations/mediawiki-config/+/541853/

QA Steps

In an incognito window where you are logged in with AMC disabled you can trigger the modal

  • Confirm that the Outreach drawers show on English Wikivoyage/MediaWiki when you click talk, history link or mobile view
  • Confirm that the dialogs show on English Wikipedia when you click talk, history link or mobile view (blocked until late Thursday/Friday when train has run)

Acceptance criteria

  • Deploy contextual hooks modal for all Wikipedias

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFri, Sep 27, 10:21 AM
ovasileva set the point value for this task to 2.Tue, Oct 1, 4:06 PM

Change 541853 had a related patch set uploaded (by Nray; owner: Nray):
[operations/mediawiki-config@master] Turn on Amc Outreach Modal (contexual hooks campaign)

https://gerrit.wikimedia.org/r/541853

nray updated the task description. (Show Details)Wed, Oct 9, 4:49 PM
Restricted Application added a subscriber: Dereckson. · View Herald TranscriptWed, Oct 9, 5:13 PM

Change 541853 merged by jenkins-bot:
[operations/mediawiki-config@master] Turn on Amc Outreach Modal (contexual hooks campaign)

https://gerrit.wikimedia.org/r/541853

Mentioned in SAL (#wikimedia-operations) [2019-10-09T23:17:17Z] <catrope@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Turn on AMC outreach modal (T234026) (duration: 00m 59s)

Edtadros claimed this task.Mon, Oct 14, 5:07 PM
Edtadros reassigned this task from Edtadros to Jdlrobson.Tue, Oct 15, 4:20 PM
Edtadros added subscribers: Jdlrobson, Edtadros.

@Jdlrobson I may have claimed this task too soon. I'm unable to get a modal to appear in enwiki.

Jdlrobson reassigned this task from Jdlrobson to Edtadros.Tue, Oct 15, 4:53 PM
Jdlrobson updated the task description. (Show Details)

^ @Edtadros QA steps missed out a vital piece of information. Hope that helps!

Edtadros reassigned this task from Edtadros to Jdlrobson.Wed, Oct 16, 2:09 PM

@Jdlrobson I think we talked about moving this to ready for signoff because I didn't have 100+ edits to test it. Is this correct?

Confirmed. I am seeing the dialog so it appears to be working.

ovasileva closed this task as Resolved.Mon, Oct 21, 10:23 AM

Works for me as well, resolving