Page MenuHomePhabricator

Reference Previews not part of "Automatically enable all new beta features"?
Closed, ResolvedPublic2 Estimate Story PointsBUG REPORT

Description

Reference Previews is now a beta feature on all Wikipedias. A user reports that they have enabled the "Automatically enable all new beta features" option, globally.

Expected behavior: The "Reference previews" beta feature will be enabled automatically.
Actual behavior: The feature was not enabled automatically. The user had to enable it manually.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 29 2019, 11:55 AM
awight added a subscriber: awight.Oct 29 2019, 2:23 PM

Thank you for the bug report! We want to fix this for sure, I believe there are thousands of people with the "automatically enable all" setting turned on. The bug also makes sense: we reused an existing preference, so I see now that we had a three-way value to handle during the migration, either enabled, disabled, or undefined. The "undefined" group with "automatically enable all" should have seen the feature enabled automatically. The bug reporter may have been in the "disabled" group somehow (this is the mysterious part).

If my guess is wrong and this affects the "undefined" group, then I'd say it's quite a high priority to fix. If it's just the "disabled" group, let's understand the number of people affected, and whether we can remove stale settings without causing an annoying experience.

awight changed the subtype of this task from "Task" to "Bug Report".

I was the one who noted that the beta feature was not enabled automatically in the linked topic. Let me know if I could be of any help :-)

Addshore removed a subscriber: TCB-Team.

@thiemowmde Can you think of any diagnostics to help understand what happened here?

I see quite a few related bugs, for example T87541: ContentTranslation beta features auto-enrollment doesn't seem to work and T64815: BetaFeatures: "Automatically enable ..." should actually automatically enable, not require visiting Special:Preferences, it's worth seeing if we have anything in common with those. Reading BetaFeaturesHooks::getPreferences, I don't see any code paths which would result in this bug, unless the Reference Previews preference had been explicitly set to disabled.

This is a direct dupe of T64815. The Beta Features auto-enroll only happens when the user preferences object is touched; there's no cron job auto-enrolling people. If you log in or edit your preferences it'll get fixed.

If you log in or edit your preferences it'll get fixed.

If I understand that correctly, you say that just logging-in to the account (or) editing an preference in Special:Preference should auto-enroll me into the "Reference previews" beta given that I have enabled the "Automatically enable all new beta features" option. Correct me if I'm wrong.

If the above understanding is correct, I just checked and that does not seem to be the case i.e.,

  • I tried re-logging into an alternate account in English Wikipedia with the "Automatically enable all new beta features" option enabled and the "Reference previews" beta feature still remains disabled.
  • I also tried changing the theme via the "Appearence" tab in Special:Preferences and the "Reference previews" beta feature still remains disabled.

This should be fixed in production, with https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/Popups/+/559010/

Please retest at your convenience.

As far as I checked this does look fixed i.e., the "Reference Previews" beta feature is enabled when the "Automatically enable all new beta features" option is enabled. Thanks for fixing this!

Wonderful. Thanks for checking!

thiemowmde set the point value for this task to 2.
WMDE-Fisch closed this task as Resolved.Tue, Jan 7, 12:31 PM
WMDE-Fisch moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2019-12-11 board.