Page MenuHomePhabricator

Newcomer tasks: in kowiki 'No suggested edits' card is displayed as default
Open, Needs TriagePublic

Description

  1. Go to kowiki wmf5( and use the hidden preference to activate Suggested edits.
  2. The Suggested edits module will be displayed as the following:
  3. When the filter button is clicked, the card changes to display an article card (there is some text overlapping in the footer of the difficulty selection overlay)

Note 1: As a work around, click the filter button - one Easy filter will be selected, click 'Done' - after that the issue will not be present.
Note 2: The samet 'No suggestion' card is present on euwiki as a default card.

Details

Related Gerrit Patches:
mediawiki/extensions/GrowthExperiments : masterSuggestedEdits: Don't error when 'links' task type doesn't exist

Event Timeline

Restricted Application added a project: Growth-Team. · View Herald TranscriptSat, Nov 9, 2:38 AM
Restricted Application added subscribers: revi, Aklapper. · View Herald Transcript
Etonkovidova updated the task description. (Show Details)Tue, Nov 12, 5:04 AM
revi added a comment.Tue, Nov 12, 9:45 AM

When I first tried, it showed something behind the checkbox, so I closed it without saving it.

Then, when I tried "select difficulty" to try other difficulties, it disappeared again.

After clicking "Done", it shows up correctly when I click "select difficulty" again.

@revi - thanks fo testing. Yes, what you described it's a workaround.

MMiller_WMF renamed this task from kowiki - 'No suggested edits' card is displayed as default to Newcomer tasks: in kowiki 'No suggested edits' card is displayed as default .Tue, Nov 12, 11:13 PM
MMiller_WMF added subscribers: Tgr, kostajh.

This is happening because the initial set of selected tasks is copyedit and links, but Korean does not have the "links" task type defined, so the initial state breaks. Once you open the dialog, only "copyedit" is selected, so it works. If you then close the dialog using the X, it reverts back to the original selection (copyedits+links), which breaks; but if you click Done, it saves the new selection (just copyedit), which works.

Change 550762 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] SuggestedEdits: Don't error when 'links' task type doesn't exist

https://gerrit.wikimedia.org/r/550762

Change 550762 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] SuggestedEdits: Don't error when 'links' task type doesn't exist

https://gerrit.wikimedia.org/r/550762

@Catrope - is the patch really merged? That what I still see in kowiki betalabs.

  1. Login to kowiki betalabs as a user with not enabled Homepage ->and enable Homepage
  2. On Homepage click to activate Suggested edits
  3. The Suggested edits module will present Easy filter as default with 'No suggestions' image
  4. Click on the filter selection button - and deselect/select the only Easy filter that it's present - the suggested edit card appears.

The sequence of screenshots is as the following;

Urbanecm added a subscriber: Urbanecm.EditedThu, Nov 14, 5:54 PM

@Catrope - is the patch really merged? That what I still see in kowiki betalabs.

  1. Login to kowiki betalabs as a user with not enabled Homepage ->and enable Homepage
  2. On Homepage click to activate Suggested edits
  3. The Suggested edits module will present Easy filter as default with 'No suggestions' image
  4. Click on the filter selection button - and deselect/select the only Easy filter that it's present - the suggested edit card appears.

The sequence of screenshots is as the following;

It seems to merged, and it also seems it managed to betalabs

urbanecm@deployment-deploy01:/srv/mediawiki-staging/php-master/extensions/GrowthExperiments$ git show HEAD
commit 868da1a9ef4383d15789a9234da019ac34eb24c1
Merge: b19cfd5 43c583b
Author: jenkins-bot <jenkins-bot@gerrit.wikimedia.org>
Date:   Thu Nov 14 14:33:36 2019 +0000

    Merge "SuggestedEdits: Don't error when 'links' task type doesn't exist"

I also verified the page is deployed to beta application servers. If it does not work, the patch itself is broken.

Thanks, @Urbanecm - I re-checked and it works. I had to create a new user to see that the issue is fixed.

I agree that this is solved.