Page MenuHomePhabricator

Regression: Label is visible on Logout button for logged in users on all wikis (non-AMC) and contribution icon on user page
Closed, ResolvedPublic

Description

Expected:
The logout icon label is not visible

Actual:
The logout label is visible

QA steps

On beta cluster (mobile) en.m.wikipedia.beta.wmflabs.org/ check

QA Results

ACStatusDetails
1T240644#5747662
2T240644#5747662

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added subscribers: Masumrezarock100, Aklapper. · View Herald TranscriptDec 13 2019, 12:04 AM
Jdlrobson triaged this task as High priority.Dec 13 2019, 12:04 AM

Change 556838 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Prevent text from showing in main-menu logout button

https://gerrit.wikimedia.org/r/556838

Change 556838 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Prevent text from showing in main-menu logout button

https://gerrit.wikimedia.org/r/556838

noting that the same issue seems to be happening with the Contributions icon and the Map icon:

The contributions icon still appears broken.
See https://en.m.wikipedia.beta.wmflabs.org/wiki/User:Jdlrobson
Can we get a fix out before the last train?

Jdlrobson renamed this task from Regression: Label is visible on Logout button for logged in users on all wikis (non-AMC) to Regression: Label is visible on Logout button for logged in users on all wikis (non-AMC) and contribution icon on user page.Dec 16 2019, 6:20 PM
Jdlrobson assigned this task to Jdrewniak.

Jan will write a fix. I will review.

Change 558164 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Add missing class to contributions icon in page-actions menu

https://gerrit.wikimedia.org/r/558164

Change 558164 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Add missing class to contributions icon in page-actions menu

https://gerrit.wikimedia.org/r/558164

Jdlrobson reassigned this task from Jdrewniak to Edtadros.Dec 16 2019, 7:24 PM
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Jdrewniak.

still seeing the contributions icon looking odd when logged out

{F31478919}
Edtadros reassigned this task from Edtadros to ovasileva.Dec 17 2019, 1:55 PM
Edtadros added a subscriber: Edtadros.

Test Result

Status: ✅ PASS
OS: macOS Catalina
Browser: Chrome
Device: MBP
Emulated Device: iPhoneX

QA steps

On beta cluster (mobile) en.m.wikipedia.beta.wmflabs.org/ check

✅ AC1: logout label on non-AMC logged in has no label

✅ AC2: check contributions icon on https://en.m.wikipedia.beta.wmflabs.org/w/index.php?title=User:Jdlrobson&mobileaction=toggle_view_mobile when using a mobile device/mobile-like responsive width is not present.

Edtadros updated the task description. (Show Details)Dec 17 2019, 1:56 PM
ovasileva closed this task as Resolved.Dec 18 2019, 10:22 AM

Seems fixed (tried on mediawiki while logged out). Resolving.

Jdlrobson reopened this task as Open.Dec 18 2019, 4:50 PM

I'm seeing the label reappear when I click it so I think we missed the hover/active state?

ovasileva removed ovasileva as the assignee of this task.Jan 6 2020, 1:08 PM

Change 562287 had a related patch set uploaded (by Jdrewniak; owner: Jdrewniak):
[mediawiki/skins/MinervaNeue@master] Remove unnecessary visited/active color from main-menu links

https://gerrit.wikimedia.org/r/562287

Change 562287 merged by jenkins-bot:
[mediawiki/skins/MinervaNeue@master] Remove unnecessary visited/active color from main-menu links

https://gerrit.wikimedia.org/r/562287

Looks fixed to me.

@Jdlrobson is there any way to check if the map gadget icon is also fixed?

Jdlrobson added a subscriber: TheDJ.Jan 9 2020, 7:02 PM

I've enabled the maps gadget (go to preferences to enable) - but it's still broken - https://en.m.wikipedia.beta.wmflabs.org/wiki/Spain?debug=true - @TheDJ are you still working on the gadget?

@Jdlrobson ok, since it's a gadget I'd be okay with moving this task along without fixing that, however if it's easy to fix at the same time that'd be great.

TheDJ added a comment.EditedJan 15 2020, 7:08 AM

seems like an easy fix for the gadget:
add mw-ui-icon-with-label-desktop to the link in the button and change the text to "Map" instead of "Show on map" seems to do it.

https://en.wikipedia.org/wiki/MediaWiki_talk:Gadget-mobilemaps.js#Interface-protected_edit_request_on_15_January_2020

Moving this along. Known issue that the map icon still has this bug, e.g. https://en.m.wikipedia.beta.wmflabs.org/wiki/Spain

ovasileva closed this task as Resolved.Jan 22 2020, 6:08 PM
ovasileva claimed this task.

Resolving