Page MenuHomePhabricator

Wikitext editor toolbar and welcome dialog give the option to switch to visual editor even if it's disabled in user preferences (or not enabled, on opt-in wikis)
Closed, ResolvedPublic

Description

Wikitext editor toolbar and welcome dialog give the option to switch to visual editor even if it's disabled in user preferences (or not enabled, on opt-in wikis).

I am about 80% sure this is unintentional.

It's particularly awkward on opt-in wikis. First of all, the editor is usually opt-in for a reason (e.g. it doesn't work well on Wiktionary because the pages are composed almost entirely of templates), and new users who follow the welcome dialog's prompt to switch will have a bad time. Secondly, after switching the visual editor is still disabled in the user's preferences, so when the user edits another page, they will see the unfamiliar wikitext editor.

On opt-out wikis, I assume anyone who opted out is an experienced editor who will just switch back, but they might be upset and feel like we're forcing the visual editor on them if we offer them a prompt to switch.

(I found this after looking into T242514 "Disable VisualEditor on Polish Wiktionary" and finding that it's already supposed to be disabled in our configuration!)

Event Timeline

matmarex created this task.Jan 26 2020, 7:36 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJan 26 2020, 7:36 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Wargo added a subscriber: Wargo.Jan 27 2020, 1:31 PM

Change 568151 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Don't offer switching to VE if it's disabled in preferences

https://gerrit.wikimedia.org/r/568151

matmarex moved this task from Incoming to In progress on the VisualEditor (Current work) board.
matmarex added a subscriber: ppelberg.

(I need to ask @ppelberg what he thinks about this)

Restricted Application added a project: VisualEditor. · View Herald TranscriptFeb 5 2020, 12:05 AM

Change 568151 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Don't offer switching to VE if it's disabled in preferences

https://gerrit.wikimedia.org/r/568151

matmarex moved this task from To Triage to Triaged on the VisualEditor board.Feb 12 2020, 5:21 PM

The way this change has been implemented is problematic. There are two settings in Special:Preferences#mw-prefsection-editing that control when VE appears: the "Temporarily disable the Visual Editor while in beta" checkbox and the "Editing mode" dropdown. I, like many other editors, only use VE for specific tasks, and mostly use the source editor. I also edit in a window that is taller than it is wide, so horizontal space is important. For this reason, I have "Editing mode" set to "Always give me the source editor". Until this change occurred, that setting meant "Always give me the source editor [first]" and I still had the ability to switch to VE.

With this change, I can't access VE at all, except through manually editing the URL query string.

If you don't want to see the visual editor, disable it. Don't disable my ability to use it.

Yes… I think that's not what was supposed to happen. *sigh*

The expected behavior is:

  • With "Temporarily disable the visual editor while it is in beta" checked:
    • You don't see the edit tab for visual editor, and you don't see the switcher in the toolbar
  • With "Temporarily disable the visual editor while it is in beta" unchecked, and "Editing mode" set to "Always give me the source editor":
    • You don't see the edit tab for visual editor, but you see the switcher in the toolbar

Right now they both behave the same (like the first case). Before the patch, they also both behaved the same, but in the opposite way (like the second case).

Change 573722 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Remove incorrect init special case for wikitext single edit tab

https://gerrit.wikimedia.org/r/573722

Change 573722 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Remove incorrect init special case for wikitext single edit tab

https://gerrit.wikimedia.org/r/573722

I think this is fixed now (and live on all wikis), and the unintended side-effect is also fixed (sorry about that!).

ppelberg closed this task as Resolved.May 21 2020, 11:58 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 21 2020, 11:59 PM