Page MenuHomePhabricator

Special:NewItem appears to have placeholder text heading "⧼Create a new Item⧽"
Closed, ResolvedPublic

Description

Event Timeline

Addshore created this task.Jun 11 2020, 7:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 11 2020, 7:22 PM
Addshore updated the task description. (Show Details)Jun 11 2020, 7:22 PM

in QQX this is ((wikibase-newitem-fieldset))

Which is weird, because it's effectively like doing {{int:{{int:wikibase-newitem-fieldset}}}} in wikitext; parse the wikibase-newitem-fieldset message first, then attempt to parse a message named whatever that message's content is.

The offending change must be this one, so adding @Umherirrender so they can look into it (and check whether the other changes in that commit cause the same behaviour).

This can't be related to mw1384 having issues. We can see it consistently.

This specific error situation does apply to Special:NewItem and Special:NewProperty and based on wrong documentation hints in the code.

Change 605284 had a related patch set uploaded (by Umherirrender; owner: Umherirrender):
[mediawiki/extensions/Wikibase@master] Fix legend message on Special:NewItem/Special:NewProperty

https://gerrit.wikimedia.org/r/605284

Change 605284 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Fix legend message on Special:NewItem/Special:NewProperty

https://gerrit.wikimedia.org/r/605284

Michael updated the task description. (Show Details)Jun 16 2020, 9:27 AM
Michael updated the task description. (Show Details)Jun 16 2020, 9:30 AM
Umherirrender closed this task as Resolved.Jun 17 2020, 4:29 PM

The fix is part of wmf/1.35.0-wmf.37 and all wikis are now at that version (https://gerrit.wikimedia.org/r/#/c/operations/mediawiki-config/+/606179/)

jhsoby reopened this task as Open.Jun 17 2020, 8:27 PM

Sorry to be reopening this, but someone in Telegram reported another thing that I think may be related:

When you try to add a new item that has the same label and description as an existing item, you get this error message. Until recently, the item was linked, but now it's just plain text. Is it caused by the same thing, or should we open a new task for it?

That is message 'wikibase-validator-label-with-description-conflict'. The message was added with https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/Wikibase/+/562782/5/repo/includes/Specials/SpecialNewItem.php (T242204) and it looks like there are no links from the begin.

I would suggest to create a new task

jhsoby closed this task as Resolved.Jun 17 2020, 9:11 PM

Aha, thank you! The message has existed since 2012, so it must have been used elsewhere (and possibly with a link then) before that commit – but in any case it has nothing to do with this task. I'll open a new one!