Page MenuHomePhabricator

On several WMF sites, CSS of Twinkle gadget is interference leading the constant display of drop down menus
Open, Needs TriagePublic

Description

In Urdu Wikipedia I find this problem that the items under the "Read" drop box such as tagging and nominating for deletion constantly being displayed.

Similar thing is noticed for user contributions.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 18 2020, 3:12 PM
Aklapper closed this task as Invalid.Jun 18 2020, 3:36 PM

Hi @hindustanilanguage, thanks for taking the time to report this! Please always follow https://www.mediawiki.org/wiki/How_to_report_a_bug and provide clear and complete steps to reproduce.

I went to https://ur.wikipedia.org/wiki/1981ء and I don't see anything like that in Firefox 77.

I could only see this problem after I enabled the Twinkle gadget on https://ur.wikipedia.org/wiki/خاص:ترجیحات#mw-prefsection-gadgets

Hence the problem here is code in a local gadget (Twinkle).

You can see which pages on your wiki are used by the Twinkle code at https://ur.wikipedia.org/wiki/میڈیاویکی:Gadgets-definition

On-wiki content like user scripts, gadgets, templates, custom CSS are local features and managed independently on each wiki.
Phabricator is mostly used for MediaWiki, MediaWiki extensions, or server configuration, or by developers and teams to organize what they plan to work on. Phabricator is not a place to ask for help with your own local code.
If you are looking for help with your own code, see https://meta.wikimedia.org/wiki/Small_wiki_toolkits#Ask_your_technical_questions instead
This needs fixing on the local wiki. Hence I am closing this task here.

The problem might come from some recent changes which were announced in https://meta.wikimedia.org/wiki/Tech/News/2020/25 :

The selectors .menu and .vectorMenu will no longer work in the Vector skin. This can affect gadgets and user scripts. .menu should be replaced by ul. .vectorMenu should be replaced by .vector-menu.

...and see also https://meta.wikimedia.org/wiki/Tech/News/2020/21 :

Some CSS for the skins has been simplified. This affects div#p-personal, div#p-navigation, div#p-interaction, div#p-tb, div#p-lang, div#p-namespaces, div#p-variants and div#footer. They will have to remove div. You will have to update your gadgets, scripts or user styles. This is so we can use HTML5.
Some CSS for the Vector skin has been changed. This affects #p-variants, #p-namespaces, #p-personal, #p-views and #p-cactions. They can no longer use > ul. You might need to update your gadgets, scripts or user styles. See how.

For the records, there are many many broken gadgets on Urdu Wikipedia. Please see https://www.mediawiki.org/wiki/Help:Locating_broken_scripts
Here is the output of https://ur.wikipedia.org/wiki/1981ء?debug=true in Firefox 77:


Please fix these broken gadgets - thanks!

Aklapper renamed this task from CSS is interference leading the constant display of drop down menus on Urdu Wikipedia to On Urdu Wikipedia, CSS of Twinkle gadget is interference leading the constant display of drop down menus.Jun 18 2020, 3:36 PM
Aklapper renamed this task from On Urdu Wikipedia, CSS of Twinkle gadget is interference leading the constant display of drop down menus to On several WMF sites, CSS of Twinkle gadget is interference leading the constant display of drop down menus.Jun 18 2020, 4:13 PM
Gnoeee added a subscriber: Gnoeee.Jun 18 2020, 6:18 PM

Same case in Malayalam Wikipedia.

provide clear and complete steps to reproduce.

You need to log in, and have Twinkle enabled, I think. See a page that is not fully protected. I encountered a similar issue on Bengali Wikipedia yesterday

Please see the comments which I added above: You will need to fix this in the local code on your wikis.
No further "The same happens on our wiki" comments needed here. :)

Restricted Application added a subscriber: alanajjar. · View Herald TranscriptJun 19 2020, 10:17 PM
Aklapper added a comment.EditedJun 20 2020, 4:30 AM

@Omar_Ghrida: Please read my comment in T255781#6235155. Gadgets are local on-wiki content.
If nobody maintains the code of some local gadgets on Urdu Wikipedia, then maybe you should consider removing some gadgets instead, or start maintaining them.

@Omar_Ghrida When checking the list of active Interface Admins, you can contact Obaid Raza as well as Yethrosh for making changes. Both of them are active. Please try putting a request in both of their talk pages. Yethrosh has actually commented the code related to Twinkle in MediaWiki gadget definition page.

Thank you @Aklapper for information, I only saw this task could be closed as resolved and also to clarify the cause of the problem that appears in the screenshots (not CSS of Twinkle gadget because the problem still exists despite the deletion of the gadget).

@Adithyak1997 I have asked MusikAnimal to fix the gadget because he can maintain the gadgets globally, but Interface administrators in the local wiki can fix it. thank you for your comment.

Hello @Aklapper , One gadgets is the cause of this problems in Urdu Wikipedia `(مام صفحات میں اوپر تاریخچہ کے بٹن کے ساتھ صفحہ کا بٹن شامل کریں، جو خانہ آلات مینو کے نیچے تجزیاتی آلات اور نوشتہ جات شامل کرتا ہے۔یہ ان اسکن پر بہتر چلتا ہے) `
According to T254797 many CSS selectors that will no longer be supported in gadgets, so this 4 pages is used in the gadget must be updated:

@MusikAnimal can you please fix these pages? thank you.

I was unable to migrate uk.wikipedia to the new MoreMenu because of missing translations. Please review them here https://meta.wikimedia.org/wiki/MoreMenu/Migration#ur.wikipedia. I asked User:Obaid_Raza about this six months ago. After I am given the translations I can deploy the gadget for you :)

Krinkle reopened this task as Open.Jun 20 2020, 5:50 PM
Krinkle added a subscriber: Krinkle.

Keeping open for now as it is an active issue on multiple issues and will be easier to find for new reporters that way.

@MusikAnimal , Unfortunately I don't understand Urdu, but I contacted the User:Obaid_Raza for tracking this task. thanks for the help.

@Krinkle Thank you for reopening this task.

2526 added a subscriber: 2526.Jun 21 2020, 5:30 AM

@Omar_Ghrida please see [[MediaWiki talk:Gadget-MoreMenu.messages.ur.js]].

@2526 thank you. @MusikAnimal Translations are available on page MediaWiki talk:Gadget-MoreMenu.messages.ur.js , is it possible to deploy the gadget ?

MusikAnimal Translations are available on page MediaWiki talk:Gadget-MoreMenu.messages.ur.js , is it possible to deploy the gadget ?

Deployed!

@MusikAnimal Excellent, thank you very much (:

Now the situation has further aggravated - I am seeing the stuff despite removing all gadget from my preferences.

I seeing all this even when I opt for edit preview.

Control+C and some other keyboard commands are also not working.