Page MenuHomePhabricator

SE article - the blue dot partially displayed after switching from source editor
Closed, ResolvedPublicBUG REPORT

Description

Found on 'cswiki wmf.39`(the issue is present in betalabs).

Steps to Reproduce:

  1. Go to SE article (on desktop), so the blue pulsing dot on 'Edit' menu will be displayed.
  2. Click on 'Edit source' - the guidance panel will display a link "Switch to the visual editor".
  3. Click on the link - the editor is switched to VE.

The pulsing blue dot will be partially obscured by the VE toolbar.

(click to animate the gif)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 9 2020, 8:25 PM
MMiller_WMF renamed this task from SE artcile - the blue dot partially displayed after switching from source editor to SE article - the blue dot partially displayed after switching from source editor.Jul 13 2020, 11:57 PM

@kostajh @Tgr @Catrope -- I think the real issue here is that the blue dot should disappear when the user clicks either edit button, even if it's not the one the dot is on. Is this the sort of thing that is super easy to change? If not, we might not do it now.

Change 612595 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Guidance: Remove pulsing dot when switching to VisualEditor

https://gerrit.wikimedia.org/r/612595

@kostajh @Tgr @Catrope -- I think the real issue here is that the blue dot should disappear when the user clicks either edit button, even if it's not the one the dot is on. Is this the sort of thing that is super easy to change? If not, we might not do it now.

It's pretty straightfforward to add in. I guess it might be confusing from a user perspective, though, because ultimately don't we want the user to click the Edit tab and not Edit source? I see the pulsing blue dot as an additional indicator to the user that they should be in VE and not wikitext.

As an alternative would it be OK to handle this specific scenario? I pushed a patch which accomplishes that -- the user clicked Edit Source instead of Edit, they click "Switch to visual editor", the blue dot goes away during that session. (But it would come back the next time they view the same task type, until they actually click "Edit" and not "Edit source"; I could change that in the patch too if you prefer.)

@kostajh -- your patch sounds fine. Let's do that. Thank you.

kostajh claimed this task.Jul 16 2020, 12:21 PM

Change 612595 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Guidance: Remove pulsing dot when switching to VisualEditor

https://gerrit.wikimedia.org/r/612595

! In T257624#6304548, @kostajh wrote:

As an alternative would it be OK to handle this specific scenario? I pushed a patch which accomplishes that -- the user clicked Edit Source instead of Edit, they click "Switch to visual editor", the blue dot goes away during that session. (But it would come back the next time they view the same task type, until they actually click "Edit" and not "Edit source"; I could change that in the patch too if you prefer.)

Works as described in @kostajh comment - checked in betalabs.

MMiller_WMF closed this task as Resolved.Jul 17 2020, 10:15 PM

Thank you!