Page MenuHomePhabricator

SE intro overlay - labels length and text positioning
Closed, ResolvedPublicBUG REPORT

Description

Several issues are reported for the SE intro overlays:

(1) RTL wikis - a regression issue, e.g. hewiki . The issue seems to be specific to the second screen in the intro overlay.

(2) cswiki has the long label running into the description

(2) The text wrapping around the image looks not balanced (see the relevant comment https://phabricator.wikimedia.org/T258016#6556575).

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 20 2020, 3:43 PM
Etonkovidova updated the task description. (Show Details)Oct 20 2020, 5:30 PM

Assuming this is about the GrowthExperiments codebase. (Please set appropriate project tags when possible. Thanks!)

Etonkovidova updated the task description. (Show Details)Oct 21 2020, 7:11 PM
Etonkovidova edited projects, added Growth-Team (Current Sprint); removed Growth-Team.
Etonkovidova updated the task description. (Show Details)Oct 21 2020, 7:23 PM
Etonkovidova updated the task description. (Show Details)Oct 21 2020, 8:09 PM

Change 635639 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] StartEditingDialog: Work around CSSJanus flipping bug

https://gerrit.wikimedia.org/r/635639

Catrope claimed this task.Oct 21 2020, 8:46 PM
Catrope moved this task from Incoming to Code Review on the Growth-Team (Current Sprint) board.

Change 635642 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] StartEditingDialog: Add padding between difficulty rows

https://gerrit.wikimedia.org/r/635642

Change 635639 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] StartEditingDialog: Work around CSSJanus flipping bug

https://gerrit.wikimedia.org/r/635639

This is issue (1).

Change 635642 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@master] StartEditingDialog: Add padding between difficulty rows

https://gerrit.wikimedia.org/r/635642

This is issue (2).

Issue (3) (or as currently written, the second issue (2)) should be addressed on T258016, by https://gerrit.wikimedia.org/r/634597

Change 635639 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] StartEditingDialog: Work around CSSJanus flipping bug

https://gerrit.wikimedia.org/r/635639

Change 635592 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.14] StartEditingDialog: Work around CSSJanus flipping bug

https://gerrit.wikimedia.org/r/635592

Change 635642 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] StartEditingDialog: Add padding between difficulty rows

https://gerrit.wikimedia.org/r/635642

Change 635594 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.14] StartEditingDialog: Add padding between difficulty rows

https://gerrit.wikimedia.org/r/635594

Change 635592 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.14] StartEditingDialog: Work around CSSJanus flipping bug

https://gerrit.wikimedia.org/r/635592

Change 635594 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.36.0-wmf.14] StartEditingDialog: Add padding between difficulty rows

https://gerrit.wikimedia.org/r/635594

Mentioned in SAL (#wikimedia-operations) [2020-10-21T23:16:01Z] <catrope@deploy1001> Synchronized php-1.36.0-wmf.14/extensions/GrowthExperiments/: T266033 (duration: 01m 05s)

Checked (1) in production - the issue is fixed.

Etonkovidova closed this task as Resolved.Oct 22 2020, 7:02 PM

Checked in wmf.14 - (1) and (2) are done. (3) will be addressed as a part of another task (see the description).