Page MenuHomePhabricator

Language code "dag" for Dagbani does not work for lexemes
Closed, ResolvedPublic3 Estimated Story Points

Description

As an editor I want to enter Lexemes in Dagbani in order to record words in the language.

Problem:
dag was added for labels on Items in T260037. It can not yet be used for Lexemes.

Comparing the list of codes the API returns for labels and lexemes, it seems dag is the only code which can be used for labels but not for lexemes. All of the other extra codes in WikibaseContentLanguages.php work fine.

Acceptance criteria:

  • dag is an allowed language for Lexemes

Notes:

  • Based on discussion with Lucas we want to add dag to the list of wmgExtraLanguageNames in wmf-config/InitialiseSettings.php

Event Timeline

Nikki created this task.Jan 17 2021, 2:07 PM

The way it's designed to work, codes which are added for labels are automatically available for monolingual text and lexemes too, but codes which have been added for monolingual text have to be added for lexemes separately (and vice versa). So, looking at the dates, I don't think it's related since that ticket is from before dag was added for labels. Back then it was working the way it was designed to, now it isn't.

(That's not to say I think it *should* work like that. I'd like to see the monolingual text and lexeme lists merged, but that's a separate issue...)

jhsoby added a subscriber: jhsoby.Mon, Feb 1, 2:34 PM
darthmon_wmde set the point value for this task to 3.Wed, Feb 3, 12:49 PM
Maintenance_bot moved this task from incoming to in progress on the Wikidata board.Wed, Feb 3, 2:15 PM

Change 662970 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[operations/mediawiki-config@master] wikidata: add Dagbani to wmgExtraLanguageNames

https://gerrit.wikimedia.org/r/662970

Change 662970 merged by jenkins-bot:
[operations/mediawiki-config@master] wikidata: add Dagbani to wmgExtraLanguageNames

https://gerrit.wikimedia.org/r/662970

Mentioned in SAL (#wikimedia-operations) [2021-02-11T12:15:16Z] <lucaswerkmeister-wmde@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Config: [[gerrit:662970|wikidata: add Dagbani to wmgExtraLanguageNames (T272242)]] (duration: 01m 29s)

Masssly reopened this task as Open.EditedMon, Feb 15, 12:40 PM

The Dropdown list in Gloss language codes for Senses does not include "dag" Dagbanli, but accepts the "dag" code anyway.

See

Nikki closed this task as Resolved.Tue, Feb 16, 9:28 AM

I'm closing this again because the issue I reported here is fixed - the language code dag is now accepted for lexemes.

The dropdown for senses not showing all languages is a separate problem which affects a number of languages. It's essentially T124758 since the sense dropdown uses the same list as monolingual text, so I've added a comment there.