Page MenuHomePhabricator

stroke-dasharray in PNG thumbnails does not support spaces as separators
Open, LowPublic

Description

Author: rainald.koch

Description:
https://commons.wikimedia.org/wiki/File:Doppler_radar_cos_factor.svg looks fine in IE9 and Firefox but is not properly converted to PNG.

stroke-dasharray is used to draw an arc (section of a circle) and to mark initial parts of several straight lines.

<circle cx="70" cy="140" r="31" fill="none" stroke-dasharray="0 170.4 33 0" />

A full circle is drawn instead of drawing only the last 1/8 of the circle (315° to 360°, after a zero-length dash and a gap of 7/8 of the circumference).

<path d="M 10 10L200 10" stroke-dasharray="61.6 333" />
There are many dashes and gaps of equal lengths instead of only one dash on the beginning of the line and a subsequent gap beyond the end of the line.

#5110 is also on stroke-dasharray, closed as FIXED. Obviously, testing is carelessly neglected.
Opened again on 2016-01-30 (T32033#1983515)


Version: unspecified
Severity: normal

Details

Reference
bz30033

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:49 PM
bzimport set Reference to bz30033.
bzimport added a subscriber: Unknown Object (MLST).
TheDJ added a comment.Jul 24 2011, 3:12 PM

well it apparently is fixed. Upstream. It's just that the rsvg software we use on the server hasn't been updated in years....

  • This bug has been marked as a duplicate of bug 24000 ***
Gilles raised the priority of this task from Normal to Unbreak Now!.Dec 4 2014, 10:27 AM
Gilles added a project: Multimedia.
Gilles moved this task from Untriaged to Done on the Multimedia board.
Gilles lowered the priority of this task from Unbreak Now! to Normal.Dec 4 2014, 11:23 AM
Perhelion reopened this task as Open.Jan 30 2016, 1:28 AM
Perhelion updated the task description. (Show Details)
Perhelion set Security to None.
Restricted Application added a project: Commons. · View Herald TranscriptJan 30 2016, 1:28 AM
Restricted Application added subscribers: Steinsplitter, Matanya, Aklapper. · View Herald Transcript
Perhelion added a subscriber: Perhelion.EditedJan 30 2016, 1:35 AM

As we can see on the initiation example the bug exist again.
Another example https://upload.wikimedia.org/wikipedia/commons/thumb/archive/6/62/20160130151712!Anne_Beadell_Highway_0116.svg/800px-Anne_Beadell_Highway_0116.svg.png
The blue dashed line should look like this https://commons.wikimedia.org/wiki/File:Anne_Beadell_Highway_0116.svg

The issue is simple that whitespaces as replacement for commas are not recognized.
is fine:

stroke-dasharray="120,20"

is not fine (but W3-conform)

stroke-dasharray="120 20"
Perhelion renamed this task from svg to png error with stroke-dasharray to SVG to PNG error with stroke-dasharray.Jan 31 2016, 1:25 PM
Perhelion updated the task description. (Show Details)
Aklapper renamed this task from SVG to PNG error with stroke-dasharray to stroke-dasharray in PNG thumbnails rendered with incorrect lengths/gaps.Mar 8 2016, 11:34 PM
Aklapper lowered the priority of this task from Normal to Low.
Ricordisamoa renamed this task from stroke-dasharray in PNG thumbnails rendered with incorrect lengths/gaps to stroke-dasharray in PNG thumbnails does not support spaces as separators.Mar 9 2016, 2:55 AM
Ricordisamoa moved this task from Backlog to Patch proposed upstream on the Upstream board.

Just a note that this is fixed in librsvg 2.42.2, just like T193352: Update librsvg to ≥2.42.3