Page MenuHomePhabricator

"Page does not exist" title cached in wrong language
Closed, ResolvedPublic

Description

If you go to the linked page and hover the non-possession red link, the title depends of the language used when the page was last parsed.

Detailed steps to reproduce:

  1. Choose your wiki. I will use the English Wikipedia as an example.
  2. Log out and delete all cookies.
  3. Go to http://en.wikipedia.org/wiki/Chandigarh_Cricket_Association?uselang=fr&action=purge and press the purge button.
  4. Go to http://en.wikipedia.org/w/index.php?title=Chandigarh_Cricket_Association&uselang=en and check the red link. It will still show the French title "Chandigarh cricket team (page inexistante)".

URL: https://translatewiki.net/wiki/User:Ellesmelle?uselang=da
See Also:
T62823: "Other languages" message is cached in the wrong language when the page is saved

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:02 AM
bzimport set Reference to bz32686.
bzimport added a subscriber: Unknown Object (MLST).

A similar issue exists in LiquidThreads as well: bug 28802

IAlex added a comment.Jan 1 2012, 2:02 PM

Fixed in r107773.

brion added a comment.Jan 3 2012, 9:22 PM

Provisionally reverted in r107941.

  • Bug 33630 has been marked as a duplicate of this bug. ***

(In reply to comment #1)

A similar issue exists in LiquidThreads as well: bug 28802

Doesn't that make this issue a duplicate and bug 28802 incorrectly classified?

This scenario is still valid:

  1. go to https://translatewiki.net/wiki/User:Ellesmelle?uselang=ar&action=purge
  2. go to https://translatewiki.net/wiki/User:Ellesmelle?uselang=en
  3. Check the title of the red link "Non-possession (de pagina bestaat niet)" (which is Dutch)

Expected behaviour: I think content should be in the content language, so the red link title should be in English in translatewiki.net.

(In reply to comment #5)

(In reply to comment #1)

A similar issue exists in LiquidThreads as well: bug 28802

Doesn't that make this issue a duplicate and bug 28802 incorrectly classified?

Maybe, but I'm not certain it's the same issue as it seems to exist longer in LiquidThreads than in core.

As I said in bug 28802, the intended language is the user interface language, which it used to be and which is preferable. If it's not possible (no longer possible?) due to caching, then it should be content language.

  • Bug 28802 has been marked as a duplicate of this bug. ***
  • Bug 35921 has been marked as a duplicate of this bug. ***

So, either we:

  • Make it fragment the cache for real (may not influence that much since factor "user language" is afaik already part of the cache key)
  • Do it in post-processing (like editsection?)
  • Make it show in content-language.

Lets just take any of those and at least have it be stable. I don't care which.

IAlex added a comment.Jun 28 2012, 9:29 PM

(In reply to comment #9)

Make it fragment the cache for real (may not influence that much since factor
"user language" is afaik already part of the cache key)

It's part of the cache key only when it's used; but displaying a TOC requires user language, so it's there for each page having a TOC (there might be more items requiring user's language, I'm just giving one of them).

  • Bug 40516 has been marked as a duplicate of this bug. ***

This was just reported at pl.wiki again[1]. I realize this has pretty minor severity, but it looks like the bug could be quickly fixed by anyone with appropriate knowledge, so could such a person maybe look into it?

[1] https://pl.wikipedia.org/w/index.php?title=Wikipedia:Kawiarenka/Kwestie_techniczne&oldid=36135008#page_does_not_exist

Can't reproduce any longer, I always see the message in interface language in all the examples.
The matter is trickier with transcluded templates, but that's another bug.

mr.heat wrote:

I don't have a problem to reproduce this with the steps described above:

  1. Choose your wiki. I will use the English Wikipedia as an example.
  2. Log out and delete all cookies.
  3. Go to http://en.wikipedia.org/wiki/Chandigarh_Cricket_Association?uselang=fr&action=purge and press the purge button.
  4. Go to http://en.wikipedia.org/w/index.php?title=Chandigarh_Cricket_Association&uselang=en and check the red link. It will still show the French title "Chandigarh cricket team (page inexistante)".
  • Bug 69905 has been marked as a duplicate of this bug. ***
Krinkle set Security to None.
Krinkle removed a subscriber: wikibugs-l-list.

Change 258736 had a related patch set uploaded (by Brian Wolff):
Make redlink tooltip be content language to stop cache pollution.

https://gerrit.wikimedia.org/r/258736

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2015, 8:55 AM
Nemo_bis updated the task description. (Show Details)Dec 13 2015, 9:07 AM

Change 258736 merged by jenkins-bot:
Make redlink tooltip be content language to stop cache pollution.

https://gerrit.wikimedia.org/r/258736

matmarex closed this task as Resolved.Jan 20 2016, 3:08 PM
matmarex assigned this task to Bawolff.
matmarex removed a project: Patch-For-Review.