Replace $wgPasswordSenderName with a system message defaulting to "{{SITENAME}}" to clarify and allow translation
Closed, ResolvedPublic

Description

I just got a notification mail from the English Wikipedia. The from fields is somewhat confusing:

From: MediaWiki Mail <wiki@wikimedia.org>

Should probably be changes to something like "Wiki[mp]edia notification system" or something in that direction. The current from field adds to the Mediawiki/Wikimedia/Wikipedia confusion.


Version: unspecified
Severity: normal
Whiteboard: gci2013
URL: http://www.google-melange.com/gci/task/view/google/gci2013/5347056445030400
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=46316
https://bugzilla.wikimedia.org/show_bug.cgi?id=46640

bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz32770.
Multichill created this task.Via LegacyDec 2 2011, 2:38 PM
MarkAHershberger added a comment.Via ConduitDec 2 2011, 5:04 PM

Looks like $wgPasswordSenderName needs to be set correctly.

Reedy added a comment.Via ConduitDec 5 2011, 5:02 PM

If we decide what we want it to be, we can configure it

Multichill added a comment.Via ConduitJan 1 2012, 3:35 PM

Please set $wgPasswordSenderName to "$wgSitename Mail". That's probably something like "$wgPasswordSenderName = $wgSitename . ' Mail';" in the configuration.

Dzahn added a comment.Via ConduitJan 2 2012, 3:35 PM

Is this an ops request to just change the current config for all projects? If yes, i see we are setting $wgPasswordSender = 'wiki@wikimedia.org'; in wmf-config/CommonSettings.php but i don't see $wgPasswordSenderName there. Is that because it was already supposed to be a per-project setting? But if we follow the suggestion we can just add it in CommonSettings.php

Besides that, is it also a Dev request to change the default settings in Mediawiki releases?

MarkAHershberger added a comment.Via ConduitJan 3 2012, 2:12 AM

(In reply to comment #4)

Is this an ops request to just change the current config for all projects?

Besides that, is it also a Dev request to change the default settings in
Mediawiki releases?

I think it could be considered both. See discussion on wikitech-l:

http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/57942

Strainu added a comment.Via ConduitJan 3 2012, 3:04 PM

(In reply to comment #3)

Please set $wgPasswordSenderName to "$wgSitename Mail". That's probably
something like "$wgPasswordSenderName = $wgSitename . ' Mail';" in the
configuration.

This SHOULD be localized, so wouldn't it be simpler to just have a message for this, which defaults to "{{SITENAME}} Mail"?

Nemo_bis added a comment.Via ConduitJan 9 2012, 7:34 AM

Clarified summary per [[mw:New Editor Engagement/Email notifications]] and wikitech thread.

Reedy added a comment.Via ConduitJan 9 2012, 7:25 PM

(In reply to comment #6)

(In reply to comment #3)
> Please set $wgPasswordSenderName to "$wgSitename Mail". That's probably
> something like "$wgPasswordSenderName = $wgSitename . ' Mail';" in the
> configuration.

This SHOULD be localized, so wouldn't it be simpler to just have a message for
this, which defaults to "{{SITENAME}} Mail"?

I'm presuming in WikimediaMessages?

Strainu added a comment.Via ConduitJan 9 2012, 8:53 PM

I have no idea what you understand by WikimediaMessages, but anyhow, I've logged a separate bug for the localization (bug 33601), since localizing means writing code, while this bug is only a site request.

Reedy added a comment.Via ConduitJan 13 2012, 12:51 AM

(In reply to comment #9)

I have no idea what you understand by WikimediaMessages, but anyhow, I've
logged a separate bug for the localization (bug 33601), since localizing means
writing code, while this bug is only a site request.

Wikimedia-specific messages (it's an extension), where things like this usually go...

siebrand added a comment.Via ConduitMar 19 2012, 4:02 PM

This shouldn't be about the WikimediaMessages extension or site requests for any specific wiki. I think that the default sender of e-mails should be reasonably identifiable, in the content language and configurable in-wiki (i.e. a system message). Something that includes SITENAME seems appropriate (and the sender name should support GRAMMAR). I'd suggest "{{SITENAME}} mail" (similar to comment 1, just not title cased).

Strainu added a comment.Via ConduitMar 19 2012, 4:27 PM

Siebrand, I've logged bug 33601 for the localization issue. I guess I was hoping this can be fixed sooner in configs and later on in the code (to actually have it localized). If you make this an i18n bug, please mark 33601 as a duplicate.

siebrand added a comment.Via ConduitMar 19 2012, 6:39 PM
  • Bug 33601 has been marked as a duplicate of this bug. ***
Nemo_bis added a comment.Via ConduitMar 19 2012, 8:32 PM

Changing summary too.
Siebrand, I may have lost track of the discussion, but why did you add "mail"? Isn't it easier to just drop it? Anyway, if it's configurable on wiki it's not a problem and I don't want to bikeshed, so let's just do it! :)

siebrand added a comment.Via ConduitMar 19 2012, 9:20 PM

Indeed :)

Krinkle added a comment.Via ConduitMar 29 2012, 11:29 AM

currently:
$wgPasswordSenderName = 'MediaWiki Mail';

Proposals so far:

  • deprecate $wgPasswordSenderName
  • replace it by an interface message that will be localized via translatewiki.net (e.g." {{SITENAME}} Mail" as value for English) (in mediawiki core that is, not Wikimedia specific at all)
  • as a side-effect allows local wikis to override it, do we want that? do we need that?
  1. deprecate $wgPasswordSenderName
  2. Just use $wgSiteName
  1. keep as is?
Strainu added a comment.Via ConduitMar 29 2012, 1:13 PM

(In reply to comment #16)

  • as a side-effect allows local wikis to override it, do we want that?

Yes, you do. You just might not know that yet... :)

(In reply to comment #16)

do we need that?

If by "we" you mean the Wikimedia wikis, probably not. It will most likely remain unchanged in most projects. But for external wikis (especially hosted ones), it might be cool to be able to change that without changing the config.

DanielFriesen added a comment.Via ConduitMar 19 2013, 9:55 AM

(In reply to comment #14)

Changing summary too.
Siebrand, I may have lost track of the discussion, but why did you add
"mail"?
Isn't it easier to just drop it? Anyway, if it's configurable on wiki it's
not
a problem and I don't want to bikeshed, so let's just do it! :)

+1

Seeing the mail reader say "You have new messages from Wikipedia" in a notification sounds more natural than "You have new messages from Wikipedia mail".

Nemo_bis added a comment.Via ConduitJul 26 2013, 6:46 AM

Relatedly, the Echo extension seems to be partially doing something like this (while adding a ton of other issues in enotifs), but I have no idea if it's configurable. See for instance how a welcome message looks like on en.wiki: https://www.mediawiki.org/w/index.php?title=Extension:GettingStarted/Welcome_enotif&oldid=686716

Nemo_bis added a comment.Via ConduitDec 25 2013, 10:49 AM

Quim, can you add this as GCI task? I should be able to review it, though not to merge.

Qgil added a comment.Via ConduitDec 27 2013, 6:46 AM

Yes, I can create a Google Code-in task out of this report, but I would welcome a clear description added here. Currently it is not clear (to me) what is the solution expected. We want to send GCI students to tasks with a clear implementation. Thank you!

Nemo_bis added a comment.Via ConduitDec 27 2013, 8:04 AM

(In reply to comment #21)

Yes, I can create a Google Code-in task out of this report, but I would
welcome
a clear description added here. Currently it is not clear (to me) what is the
solution expected. We want to send GCI students to tasks with a clear
implementation. Thank you!

The summary has summarised the discussion so far. It's about moving the configuration variable to a system message with a different default.

Qgil added a comment.Via ConduitDec 29 2013, 5:51 AM

Thank you for the clarification. GCI task created.

gerritbot added a comment.Via ConduitDec 31 2013, 6:21 AM

Change 104707 had a related patch set uploaded by Theopolisme:
Replace $wgPasswordSenderName with a system message

https://gerrit.wikimedia.org/r/104707

gerritbot added a comment.Via ConduitJan 2 2014, 6:14 PM

Change 104707 merged by jenkins-bot:
Deprecate $wgPasswordSenderName

https://gerrit.wikimedia.org/r/104707

siebrand added a comment.Via ConduitJan 2 2014, 6:59 PM

Gerrit 104707 deprecates $wgPasswordSenderName and allows in-wiki configuration of the password sender name in the wiki page [[MediaWiki:Emailsender]], defaulting to {{SITENAME}} in the content language for all emails sent from MediaWiki core. Some extensions that send emails can still be using $wgPasswordSenderName and this is expected to be phased out over time.

Add Comment