Upload Wizard cannot find all JS resources in several languages
Closed, ResolvedPublic

Description

Extract from an IRC log:

[12:14] <strainu> I'm having a problem with the upload wizard in Romanian
[12:14] <strainu> the page loads, but the JS doesn't

[12:26] <thedj[work]> strainu: got it, seems an issue with wmf12 deploy
[12:26] <thedj[work]> https://bits.wikimedia.org/static-1.20wmf12/resources/mediawiki.language/languages/ro.js Failed to load resource: the server responded with a status of 404 (Not Found)

This is affecting Wiki Loves Monuments right now.


Version: unspecified
Severity: major

bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz40380.
Strainu created this task.Via LegacySep 20 2012, 9:32 AM
TheDJ added a comment.Via ConduitSep 20 2012, 9:37 AM
  • Bug 40383 has been marked as a duplicate of this bug. ***
TheDJ added a comment.Via ConduitSep 20 2012, 9:37 AM
  • Bug 40382 has been marked as a duplicate of this bug. ***
Strainu added a comment.Via ConduitSep 20 2012, 9:39 AM

According to http://commons.wikimedia.org/wiki/Commons:Village_pump#UploadWizard_asleep en, de, ru work, but ro and fr don't.

TheDJ added a comment.Via ConduitSep 20 2012, 9:40 AM

Likely it affects all languages with plural rules.

hashar added a comment.Via ConduitSep 20 2012, 9:42 AM

I guess I will just restore the old plural rules in wmf12.

tomasz added a comment.Via ConduitSep 20 2012, 9:49 AM

Raising importance and priority, marking as blocker of bug 38648.

This bug is affecting thousands of users every hour, and needs to be fixed
ASAP.

hashar added a comment.Via ConduitSep 20 2012, 10:01 AM

I am pretty sure the culprit is https://gerrit.wikimedia.org/r/#/c/23874/ since it deleted the file. Probably forgot to update the resourceloader so I am just reverting it wich is https://gerrit.wikimedia.org/r/#/c/24424/ .

hashar added a comment.Via ConduitSep 20 2012, 10:14 AM

Backported to wmf12 with https://gerrit.wikimedia.org/r/#/c/24425/ and synced with:

sync-dir php-1.20wmf12/resources/mediawiki.language

That might solve the issue since it provides the files back.

tomasz added a comment.Via ConduitSep 20 2012, 11:05 AM

People report that the UploadWizard works for them now (at least in Romanian, French and Polish), therefore I am closing this bug as RESOLVED FIXED.

Thanks for such a prompt response, hashar!

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.