Page MenuHomePhabricator

[TUX] Unclear filtering completion status
Closed, ResolvedPublic

Description

When filtering the message list, it is confusing to know whether the filtering is complete because:

  • The loading indicator is shown despite no more messages are not loading
  • The message "Found 1 result for X" does not provide an indication about the search being complete or not.

Version: master
Severity: normal

Details

Reference
bz45434

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:27 AM
bzimport set Reference to bz45434.

(In reply to comment #0)

  • The loading indicator is shown despite no more messages are not loading

Is this assumption verified?

It is hard to verify if loading indicator will disappear at some point or it is running forever. But I think the problem persists.

Some steps to reproduce:

  • Bug 45733 has been marked as a duplicate of this bug. ***

Looks like it only loads one batch of messages more. Perhaps it is related to the fact that the loader never gets hidden in the between like it usually does.

Duplicate message whiile filtering long message list is happening now

We observe multiple API threads, that also makes the "x messages left to load" count go up. That's probably the root cause for the observation in comment 6.

I think that the original bug is resolved. I reported duplicate results as Bug 47198.

Closing again per comment 8.