Page MenuHomePhabricator

localize display of time values
Closed, ResolvedPublic

Description

Time-related values should be displayed using the user's time formatting preferences.


Version: master
Severity: major
Whiteboard: u=dev c=backend p=0

Details

Reference
bz48962

Related Objects

StatusAssignedTask
ResolvedNone
OpenNone
ResolvedLydia_Pintscher
ResolvedNone
Resolvedadrianheine
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
ResolvedNone
Resolvedadrianheine
DeclinedNone
DeclinedNone
Openthiemowmde
ResolvedNone

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:42 AM
bzimport set Reference to bz48962.
bzimport added a subscriber: Unknown Object (MLST).

li3939108 wrote:

YYYY-MM-DD is very OK for Chinese. Something like "Jan 20 2013" seems rather strange when internationalized but not localized.

  • Bug 49041 has been marked as a duplicate of this bug. ***

There is a partial solution implemented in the frontend in Change-Id: I093af8477b1bba7ea3fca497d03561a9c52b8d93.

This does reordering of day, month and year according to the user preference. However this does not support all available settings in MW and will fall back to "mdy" for not supported settings.

Tpt added a comment.Oct 8 2013, 3:07 PM

I've submitted Change-Id: Ib2073071b5d46eaf9cbd1d09ac92a842a0ef4233 that change wgPageContentLanguage to the language of the displayed content (ie, for Wikibase entities, the user language). If this change is merged, wgDefaultDateFormat will be, for entities, in the user language and may be used as default format for dates, if the user haven't configure anything.

Since time parsing is now done in the backend we should rethink this change.

  • Bug 67194 has been marked as a duplicate of this bug. ***

In some languages, such as Hebrew it isn't correct to write "27 June" but instead "27th of June"

[in Hebrew:
27 יוני - wrong
27 ביוני - correct
]

The correct way to define format of day and month is "j xg" and not "j F". (The same way as it is defined in preferences)

see related change: https://gerrit.wikimedia.org/r/#/c/142519/

  • Bug 68236 has been marked as a duplicate of this bug. ***
  • Bug 68622 has been marked as a duplicate of this bug. ***
  • Bug 62385 has been marked as a duplicate of this bug. ***

Date format for Hungarian is broken.
Instead of "1970. január 1." it is "1 január 1970" This is also valid for the {{#property}} parser function on huwiki. It was fine in November 2013. Why it has changed?

Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Snaevar removed a subscriber: Snaevar.Feb 13 2015, 6:46 PM
Ricordisamoa added a subscriber: Ricordisamoa.
hoo moved this task from incoming to ready to go on the Wikidata board.Mar 5 2015, 3:38 PM
hoo added a subscriber: hoo.
Pasleim added a subscriber: Pasleim.Mar 5 2015, 3:45 PM
Mps added a subscriber: Mps.Mar 25 2015, 8:35 PM

Suggestion from the sprint planning meeting:

  • We currently do not have a formatter that can format datetime values as MediaWiki core does/as MediaWiki users expect.
  • Core does have two formatters, one is used in parser functions and not aware of user preferences. We think that's the one we should use.
  • We support a much wider range of datetime values. The suggestion is to implement a formatter that uses core's formatter for everything that can be formatted that way, and a "sane" fallback for everything else.
  • What "sane" means is up for discussion. Personally I suggest to start with whatever we agree on in the team and improve this later, based on comments and tickets from the community.

Change 202455 had a related patch set uploaded (by Hoo man):
Allow wikibase-time-precision-* to be translated, expand Qqq

https://gerrit.wikimedia.org/r/202455

Change 202455 merged by jenkins-bot:
Allow wikibase-time-precision-* to be translated, expand Qqq

https://gerrit.wikimedia.org/r/202455

hoo added a comment.Apr 8 2015, 5:16 PM

IMO this bug is solved, as these can be localized now... but we should probably create some bug about having a better (more flexible) localization system than we have now.

Lydia_Pintscher closed this task as Resolved.Apr 9 2015, 9:27 AM
Lydia_Pintscher claimed this task.