TemplateData: Display a useful message instead of an empty table for templates that take no parameters
Closed, ResolvedPublic

Description

Currently, if you use TemplateData for a template without any parameters, you still have to create an empty "params" in the JSON (not really important), but you also end up with a "Template parameters" table with just the title line (Parameter Description Type Default Status).

Rather than displaying an empty table, I think it would be better to display no table at all, or a simple message saying that no parameters are defined for this template.


Version: unspecified
Severity: minor

bzimport added a project: TemplateData.Via ConduitNov 22 2014, 2:01 AM
bzimport set Reference to bz51429.
NicoV created this task.Via LegacyJul 16 2013, 7:36 AM
Jdforrester-WMF added a comment.Via ConduitApr 28 2014, 6:52 PM
  • Bug 62417 has been marked as a duplicate of this bug. ***
Ricordisamoa added a subscriber: Ricordisamoa.Via WebJan 12 2015, 8:50 PM
Jdforrester-WMF moved this task to Next-up on the TemplateData workboard.Via WebJan 12 2015, 9:16 PM
Lokal_Profil added a subscriber: Lokal_Profil.Via WebJan 15 2015, 2:05 PM

It would also be useful if you could set "no parameters" in the TemplateData so that VisualEditor does not suggest adding a parameter for these templates.

gerritbot added a subscriber: gerritbot.Via ConduitFeb 19 2015, 1:12 AM

Change 191518 had a related patch set uploaded (by Mooeypoo):
Display a message when no parameters are defined

https://gerrit.wikimedia.org/r/191518

Patch-For-Review

Mooeypoo claimed this task.Via WebFeb 19 2015, 1:12 AM
Mooeypoo moved this task to Doing on the TemplateData workboard.Via WebFeb 19 2015, 1:17 AM
Jdforrester-WMF closed this task as "Resolved".Via WebFeb 19 2015, 1:48 AM
Jdforrester-WMF set Security to None.
gerritbot added a comment.Via ConduitFeb 19 2015, 1:48 AM

Change 191518 merged by jenkins-bot:
Display a message when no parameters are defined

https://gerrit.wikimedia.org/r/191518

Etonkovidova added a subscriber: Etonkovidova.Via WebFeb 23 2015, 11:03 PM

The fix in beta:

vs test2:

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.