Page MenuHomePhabricator

Deprecated: Use of SpecialRecentChangesQuery hook (used in TranslateRcFilter::translationFilter)
Closed, ResolvedPublic

Description

Deprecated: Use of SpecialRecentChangesQuery hook (used in TranslateRcFilter::translationFilter) was deprecated in MediaWiki 1.23. [Called from wfRunHooks in /mnt/vagrant/mediawiki/includes/GlobalFunctions.php at line 4009] in /mnt/vagrant/mediawiki/includes/debug/Debug.php on line 303 Deprecated: Use of SpecialRecentChangesQuery hook (used in CCFilters::user) was deprecated in MediaWiki 1.23. [Called from wfRunHooks in /mnt/vagrant/mediawiki/includes/GlobalFunctions.php at line 4009] in /mnt/vagrant/mediawiki/includes/debug/Debug.php on line 303

Details

Reference
bz65776
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:23 AM
bzimport set Reference to bz65776.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.May 26 2014, 5:32 PM

Because Translate is backwards compatibel with MediaWiki 1.21 and later, this Development warning is not relevant. Please use the appropriate global to suppress deprecation warnings when using Translate in development mode.

The current practice is to fix deprecation warnings.

In some rare cases that might have been delayed if keeping BC while doing that is especially difficult, but this likely isn't one of them.

  • Bug 66040 has been marked as a duplicate of this bug. ***

Marking as high because the hooks will stop working at some point if we don't implement the replacements of these hooks.

Uh this one is messy. The new hooks were introduced in 1.23 (but no @since tags, nor mentioned in release notes). Also, there were some follow-ups to them which are only in 1.24. It looks like we shouldn't use these hooks until 1.24 is the minimum version.

PS: I can't find to escape stuff like @ in Phabricator to avoid special processing.

The new hooks were introduced in 1.23 (but no @since tags, nor mentioned in release notes).

I don't think there's a way to add @since tags for hooks, and we don't usually mention hook additions in release notes. We do usually mention deprecations, but it seems there was no release note for this one :(

Also, there were some follow-ups to them which are only in 1.24. It looks like we shouldn't use these hooks until 1.24 is the minimum version.

Yes, Thiemo discovered that the hooks weren't being fired correctly in 1.23 and fixed it in 1.24 (08fee4ce2f1bbf362c8422a3e306a905c8775094). My fault from a4aa71c6cf7eba2322139312ad8353f1c318c06f, I was originally planning to do this differently and got confused.

PS: I can't find to escape stuff like @ in Phabricator to avoid special processing.

You can escape all syntax by wrapping the block in %%% (three percent signs). This only works for blocks, same as ```; there isn't a more granular way, it's all-or-nothing for the entire paragraph.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 24 2016, 5:13 PM
Nikerabbit lowered the priority of this task from High to Medium.Apr 20 2016, 1:40 PM
Nikerabbit added a project: Technical-Debt.

1.25 is now the minimum version, should make it easier to update.

Change 286292 had a related patch set uploaded (by Glaisher):
Migrate TranslateRcFilter::translationFilter to ChangesListSpecialPageQuery hook

https://gerrit.wikimedia.org/r/286292

Nikerabbit closed this task as Resolved.May 3 2016, 10:52 AM
Nikerabbit assigned this task to Glaisher.
Nikerabbit edited projects, added Language-Q4-2016-Sprint 2; removed Patch-For-Review.
Nikerabbit updated the task description. (Show Details)
Nikerabbit moved this task from Backlog to Done on the Language-Q4-2016-Sprint 2 board.
Nikerabbit removed a subscriber: wikibugs-l-list.

Change 286292 merged by jenkins-bot:
Migrate TranslateRcFilter::translationFilter to ChangesListSpecialPageQuery hook

https://gerrit.wikimedia.org/r/286292