Page MenuHomePhabricator

IE (9, 10 and 11) compatibility: Card does not show on 2nd hover of same link; Images are not displayed
Closed, ResolvedPublic

Description

For first issue, see https://www.mediawiki.org/w/index.php?title=Talk:Beta_Features/Hovercards&workflow=rwbsj2o174xuzeov

Replication instructions:
0: find machine with internet explorer (verified with IE10 on win7, IE11 on win7 and win8.1)
1: open enwiki, log in, activate hovercards
2: hover over a link and make sure card appears
3: stop hovering, see the card disappear
4: hover over same link again
EXPECTED RESULTS: card should appear again
OBSERVED RESULTS: the card appears empty, with height=0. the little triangle is still there, and the upper and lower borders of the card are shown basically merged to one horizontal line.

ISSUE #2:
(repeat steps 0,1,2 from above, for a link to an article with an image):
Notice that the image appears to be broken.
this issue is only verified with IE10 on win7. it may or may not happen with IE11.

peace.

Problem captured in this video:

Version: unspecified
Severity: normal

Details

Reference
bz66496

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:20 AM
bzimport set Reference to bz66496.
bzimport added a subscriber: Unknown Object (MLST).
Kipod created this task.Jun 11 2014, 7:47 PM

Created attachment 15729
empty hovercard

Attached:

Created attachment 15730
no image on hovercard

Attached:

geraki added a subscriber: geraki.Apr 17 2015, 7:39 AM

I also happens in IE11 on Win7.

The empty hovercard may or not have a full frame.

Different links to the same article behave differently and changing behaviour:

  • Hovercard with text but no image
  • Empty hovercard but with the dimensions of a full hovercard
  • Empty hovercard with 0 height

Prtksxna claimed this task.Apr 17 2015, 7:46 AM
Prtksxna set Security to None.

Thanks for updating this @geraki. I am looking into it right now.

Change 207389 had a related patch set uploaded (by Prtksxna):
Use correct selector for div's that hold PNGs when SVGs aren't supported

https://gerrit.wikimedia.org/r/207389

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 19 2015, 7:35 AM
Jdlrobson lowered the priority of this task from High to Normal.Sep 25 2015, 4:46 PM
Jdlrobson added a subscriber: Jdlrobson.

Patch is -1ed
Let me know if this is still being worked on.

Jdlrobson changed the task status from Open to Stalled.Oct 9 2015, 5:49 PM
Prtksxna changed the task status from Stalled to Open.Oct 15 2015, 3:50 PM
Prtksxna removed a project: Patch-For-Review.
Prtksxna removed Prtksxna as the assignee of this task.Nov 13 2015, 1:44 PM
Jdlrobson lowered the priority of this task from Normal to Low.Dec 7 2015, 4:44 PM

Change 288552 had a related patch set uploaded (by Jdlrobson):
Do not directly manipulate the cached object

https://gerrit.wikimedia.org/r/288552

Tests are great...

Change 288552 merged by jenkins-bot:
Do not directly manipulate the cached object

https://gerrit.wikimedia.org/r/288552

phuedx closed this task as Resolved.May 18 2016, 9:31 AM
phuedx claimed this task.
phuedx added a subscriber: phuedx.

I've tested 288552: Do not directly manipulate the cached object in IE9 and IE10 on Windows 7, and Chrome (50.0.2661.102) on OS X (10.11.5) and I believe that this is fixed. If you find that the issue is still present in IE11, then please reopen the task.

MBinder_WMF moved this task from 2017-18 Q2 to 2015-16 Q4 on the Readers-Web-Backlog board.