Page MenuHomePhabricator

C9. "Mark all as read" button can't be found by browser tests
Closed, ResolvedPublic1 Story Points

Description

User with messages in Echo flyout should have a "Mark all as read" button, but does not. See screen shot.

This is the browser test failure at
https://integration.wikimedia.org/ci/job/browsertests-Echo-en.wikipedia.beta.wmflabs.org-linux-firefox-sauce/34/


Version: unspecified
Severity: normal

See also:

Details

Reference
bz70298

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 3:41 AM
bzimport set Reference to bz70298.
bzimport added a subscriber: Unknown Object (MLST).

Created attachment 16344
Mark all as read button gone missing

Attached:

  • Bug 70297 has been marked as a duplicate of this bug. ***
  • This bug has been marked as a duplicate of bug 70329 ***

Jon, Bug 70329 - "Message notifications not working" - doesn't sound like this bug, so I'm un-dupe-ing.

I am seeing "Mark all as read" on ee-flow and beta labs when I have notifications from Flow in the Messages pane. Looking at the attached screenshot, Messages(0) means you have zero unread message notifications and they all look gray, so there is indeed no "Mark all as read".

(The old way "Mark as read" worked is if you had more alerts than the non-scrolling flyout could show, "Mark all as read" would mark all the notifications as read, not just the ones appearing in the flyout.)

Thanks S, so this is a feature not a bug.

The failure is due to the other bug.

So it *is* a bug. :-)

I'll leave the failing test as is for now then.

This is failing for another reason - the default tab was changed and the test was not updated - there needs to be a new step "And I switch to the messages tab"

Change 159685 had a related patch set uploaded by Spage:
QA: update Echo messages test

https://gerrit.wikimedia.org/r/159685

Change 159685 abandoned by Cmcmahon:
QA: update Echo messages test

Reason:
overtaken by history: https://gerrit.wikimedia.org/r/#/c/160477/

https://gerrit.wikimedia.org/r/159685

At a quick glance, it seems the
"And I have a Flow message that triggers an alert notification"

isn't happening. The Echo notification badge count doesn't go to 2, there's no recent message in the messages tab.

For that matter, there's no recent alert in the alerts tab. Alerts are marked on view, but I would expect to see something more recent in there than "1 day ago"

It might be delayed notifications: to check see if 'Selenium user firefox' has more recent messages.

I'm not getting any Flow Notifications at beta.wmflabs. I replied to myself and thanked myself (via a testaccount) at http://en.wikipedia.beta.wmflabs.org/wiki/Topic:S3bmb9jyd5l7c34i - I got the Thank notification instantly, but the Flow-reply notifications have not shown up after 1 hour.

I filed bug 71484 for the general problem of Flow notifications on beta labs.

He7d3r updated the task description. (Show Details)
He7d3r set Security to None.

This is still an issue. If you don't care about the browser tests you should probably disable them... (but I highly encourage you to rethink this if it is the case)

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMar 30 2015, 5:25 PM
Moushira removed a subscriber: Moushira.

I've flagged this to be estimated; we should definitely highly consider it for our next sprint.

Where are you missing the "mark all as read" link? I can see it, on both mediawiki and enwiki.

Note that it doesn't appear on the Alerts tab, and does appear on the Messages tab.

Here's screenshots I just took from enwiki.

Mattflaschen-WMF renamed this task from "Mark all as read" button gone missing to "Mark all as read" button can't be found by browser tests.Apr 1 2015, 3:42 AM
DannyH edited a custom field.Apr 1 2015, 6:15 PM
DannyH renamed this task from "Mark all as read" button can't be found by browser tests to C9. "Mark all as read" button can't be found by browser tests.Jun 3 2015, 7:14 PM

The recent build https://integration.wikimedia.org/ci/view/BrowserTests/view/Echo+Flow/job/browsertests-Echo-en.wikipedia.beta.wmflabs.org-linux-firefox-sauce/528/ is green.

The scenario Scenario: Mark all as unread # features/messages.feature:4 is present and seems to be passing.

What was checked:

Catrope closed this task as Resolved.Jun 11 2015, 5:34 PM