Page MenuHomePhabricator

mobile redirect only works on canonical URLs
Closed, ResolvedPublic

Description

On a mobile device visit...
https://en.wikipedia.org/w/index.php?title=Cat
...then visit...
https://en.wikipedia.org/wiki/Cat

Expected result: both redirect to mobile view (en.m.wikipedia.org)

Actual result: only the canonical URL redirects to the mobile view

I can only reproduce this bug on the cluster and beta labs. On my local machine, both URLs redirect properly.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=61489

Details

Reference
bz70312

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:42 AM
bzimport set Reference to bz70312.
bzimport added a subscriber: Unknown Object (MLST).
kaldari created this task.Sep 2 2014, 11:42 PM

bingle-admin wrote:

Prioritization and scheduling of this bug is tracked on Trello card https://trello.com/c/422pJjh6

Hmm, still seems to be broken on beta labs :(

According to Max this is on purpose. Non-canonical URLs are not redirected by Varnish in order to avoid causing issues with API calls, etc.

Max for completeness can you elaborate? What caching problems might arise?

MaxSem added a comment.Sep 4 2014, 5:07 PM

(In reply to Jon from comment #5)

Max for completeness can you elaborate? What caching problems might arise?

Where did anyone say anything about caching? :P
It's different kind of problems: you make an API request but suddenly get a redirect, etc.

Could we blacklist API URLs from the redirect rules?

We can. However, index.php and other entry points definitely have their own corner cases, that's why we should only redirect if we're 101% sure it's only a page view.

MaxSem: So you're suggesting that we should only redirect page views and not things like diffs or action=edit, etc.? In that case we should close bug 61489 as WONTFIX and revert the changes that were made to facilitate that.

Another possibility would be to specifically whitelist diff URLs for redirection. What do you think of that idea?

Jdlrobson set Security to None.
Mattflaschen-WMF reopened this task as Open.Aug 1 2015, 2:50 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 1 2015, 2:50 AM
Catrope triaged this task as Normal priority.Aug 5 2015, 11:15 PM
Catrope moved this task from Untriaged to Team discussion on the Collaboration-Team-Triage board.
Catrope added a subscriber: Catrope.
MaxSem removed a subscriber: MaxSem.Aug 18 2015, 5:10 PM
Jdlrobson closed this task as Resolved.Jul 28 2016, 8:38 PM
Jdlrobson claimed this task.

Seems to WFM in an incognito window....