Page MenuHomePhabricator

support regular action=purge
Closed, ResolvedPublic

Description

The first expression in the following paragraph:

Die beiden letzten Ausdrücke für <math>x_{1}^{*}</math> und <math>x_{2}^{*}</math> sind nichts anderes als die jeweiligen ''marshallschen Nachfragefunktionen nach Gut 1 bzw. Gut 2.''

is not rendered properly in MathML mode (no problems with MathJax and PNG), resulting instead in the following error message:

Fehler beim Parsen (MathML mit SVG- oder PNG-Rückgriff (empfohlen für moderne Browser und Barrierefreiheitswerkzeuge): Ungültige Antwort („<p>Fehler beim Abruf der URL: Empty reply from server </p>“) von Server „http://mathoid.svc.eqiad.wmnet:10042“:): x_{1}^{*}

(From https://de.wikipedia.org/w/index.php?title=Marshallsche_Nachfragefunktion&oldid=134992435#Beispiel_im_Zwei-G.C3.BCter-Fall)


Version: master
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=72536

Details

Reference
bz72537

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:51 AM
bzimport added a project: Math.
bzimport set Reference to bz72537.
bzimport added a subscriber: Unknown Object (MLST).
pajz created this task.Oct 26 2014, 5:28 PM

This looks like a math caching problem to me, as purging that page with ?action=purge&mathpurge=true clears it. (The mathpurge=true bit is currently necessary as the math extension doesn't seem to properly get access to the action parameter; hopefully that can be dropped soon.)

The Math extension stores rendered math in the database. I think it should not do this if there was a (temporary) error from the backend server. I'm re-titling this bug to mention both issues.

  • Bug 72536 has been marked as a duplicate of this bug. ***

physik wrote:

If there is an error on the page nothing should be stored in the database. So I would be surprised if normal &acition=purge would not be sufficient in this situation.
Quite a few people tried to implement the access to the purge parameter. All failed. So I think this should be a bug on it's own.

physik wrote:

See MathRenderer.php l 520 ff

		// TODO: Figure out if ?action=purge
		// $action = $request->getText('action'); //always returns ''
		// until this issue is resolved we use ?mathpurge=true instead
Physikerwelt moved this task from Incoming to Next-up on the Math board.Dec 9 2014, 3:47 AM
gerritbot added a subscriber: gerritbot.

Change 189448 had a related patch set uploaded (by Physikerwelt):
Support regular action purge

https://gerrit.wikimedia.org/r/189448

Patch-For-Review

Change 189448 abandoned by Physikerwelt:
WIP: Support regular action purge

Reason:
this is not important at the moment

https://gerrit.wikimedia.org/r/189448

Change 197242 had a related patch set uploaded (by Physikerwelt):
WIP: Support regular action purge

https://gerrit.wikimedia.org/r/197242

Physikerwelt triaged this task as Normal priority.Mar 20 2015, 2:59 PM
Physikerwelt set Security to None.
Physikerwelt removed a project: Patch-For-Review.
Physikerwelt added a subscriber: Physikerwelt.

The WIP patch is not really ready for review.

Physikerwelt moved this task from Next-up to Blocked: needs help on the Math board.Feb 2 2016, 4:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 2 2016, 4:52 PM

Change 197242 abandoned by Physikerwelt:
WIP: Support regular action purge

Reason:
purge does not work anymore for math anyhow since cache is now handled by restbase

https://gerrit.wikimedia.org/r/197242

jayvdb added a subscriber: jayvdb.May 26 2016, 2:52 AM

Is this now Invalid, then?

Change 342869 had a related patch set uploaded (by Physikerwelt):
[mediawiki/extensions/Math] Purge formulae on action=purge

https://gerrit.wikimedia.org/r/342869

Change 342869 merged by jenkins-bot:
[mediawiki/extensions/Math@master] Purge formulae on action=purge

https://gerrit.wikimedia.org/r/342869

Debenben closed this task as Resolved.Nov 11 2018, 7:36 PM
Debenben claimed this task.