Page MenuHomePhabricator

Creating directory with special characters
Closed, ResolvedPublic

Description

I tried to use http://commons.wikimedia.beta.wmflabs.org/wiki/Special:GWToolset with User:Léna but found the following error message (I guess related to the "é" in my user name ?)

[cef046e1] /wiki/Special:GWToolset MWException from line 406 of /srv/mediawiki/php-master/extensions/GWToolset/includes/Helpers/GWTFileBackend.php: <p>Please contact a developer. This issue must be addressed before you can continue. Please add the following text to your report:
</p><p>GWToolset\Helpers\GWTFileBackend::saveFile: Could not create directory "mwstore&#58;//gwtoolset-backend/gwtoolset-metadata/Léna/d/3/f".
</p>

Backtrace:

#0 /srv/mediawiki/php-master/extensions/GWToolset/includes/Handlers/UploadHandler.php(642): GWToolset\Helpers\GWTFileBackend->saveFile(Php\File)
#1 /srv/mediawiki/php-master/extensions/GWToolset/includes/Handlers/Forms/MetadataDetectHandler.php(204): GWToolset\Handlers\UploadHandler->saveMetadataToFileBackend()
#2 /srv/mediawiki/php-master/extensions/GWToolset/includes/Handlers/Forms/FormHandler.php(176): GWToolset\Handlers\Forms\MetadataDetectHandler->processRequest()
#3 /srv/mediawiki/php-master/extensions/GWToolset/includes/Specials/SpecialGWToolset.php(119): GWToolset\Handlers\Forms\FormHandler->execute()
#4 /srv/mediawiki/php-master/extensions/GWToolset/includes/Specials/SpecialGWToolset.php(72): GWToolset\SpecialGWToolset->processRequest()
#5 /srv/mediawiki/php-master/includes/specialpage/SpecialPage.php(363): GWToolset\SpecialGWToolset->execute(NULL)
#6 /srv/mediawiki/php-master/includes/specialpage/SpecialPageFactory.php(589): SpecialPage->run(NULL)
#7 /srv/mediawiki/php-master/includes/MediaWiki.php(275): SpecialPageFactory::executePath(Title, RequestContext)
#8 /srv/mediawiki/php-master/includes/MediaWiki.php(584): MediaWiki->performRequest()
#9 /srv/mediawiki/php-master/includes/MediaWiki.php(435): MediaWiki->main()
#10 /srv/mediawiki/php-master/index.php(46): MediaWiki->run()
#11 /srv/mediawiki/w/index.php(3): include(string)
#12 {main}

Event Timeline

Lena created this task.Nov 24 2014, 11:01 AM
Lena raised the priority of this task from to High.
Lena updated the task description. (Show Details)
Lena changed Security from none to None.
Lena added a subscriber: Lena.
Gilles lowered the priority of this task from High to Normal.Nov 24 2014, 2:16 PM
Gilles added a subscriber: Gilles.

Hmmm, I never had any problem with the GWToolset, and I certainly have my fair share of special characters in my username… :-/

JeanFred added a subscriber: dan-nl.Dec 1 2014, 7:05 PM

Cc-ing Dan.

Krinkle added a subscriber: Krinkle.Dec 6 2014, 7:39 PM
Lena added a comment.Feb 18 2015, 4:09 PM

Hi everyone.

I'm sorry if this sounds harsh but I really need to say it.

This bug has been opened three months ago, and prevents me from uploading high quality pictures from a GLAM partner. During these three months, I didn't receive any kind of information regarding if someone is currently working on the issue or not, and if and when the bug will be corrected. This is not acceptable.

Correcting bugs is my job. I can understand backlogs, I cannot understand silence. Can I expect a resolution within the next month ? quarter ? in a year or more, meaning never ?

Just to give you a bit of perspective, Multimedia is staffed by 3 engineers. We have 20+ extensions to maintain and currently a backlog of approximately 1400 tasks. @dan-nl used to maintain GWToolset on a volunteer basis but probably hasn't had time lately, since I haven't seen him be very active in the last few months.

I understand your frustration, but unfortunately due to our very limited resources we tend to favor bugs that affect a lot/all users, because we already have more of those than we can handle in our backlog. Which is probably why this wasn't marked as high priority and started collecting dust in the backlog. It's hard to make promises on a specific bug.

The fact that this is an open source project helps, but GWToolset in particular doesn't have a volunteer contributors community yet, like other extensions might. If our team doesn't get to this particular bug soon, I will at least remember to mark it for the next batch of volunteer bugfixing event we participate in.

Since you state that correcting bugs is your job, by all means, if you submit a patch for this I will gladly review it. I try my best to review volunteer contributions we receive for the extensions we're responsible for within two weeks of submission.

Lena added a comment.Feb 18 2015, 4:32 PM

Gilles it's really ok that this bug will not be corrected any time soon. (Well no it's not but it's not your fault :) I understand the burden of understaffing and the painful logical consequence of having to only work on very critical bugs). My main issue was with the lack of communication, I don't know how it can be done. Maybe an automatic email sent when a task has its priority set to normal saying to not expect a correction before a looooong time ?

Tgr added a subscriber: Tgr.Feb 18 2015, 7:17 PM

https://phabricator.wikimedia.org/project/sprint/profile/1015/ has a nice priority/expected arrival chart, I wonder if it would make sense to do something similar for Multimedia.

Tgr added a comment.Feb 18 2015, 7:18 PM

As a workaround, you can try to register another user for this, although as Jean-Fred said, GWT does not seem to have any problem with é in usernames.

I can't reproduce this (locally using the username Léna, and on beta commons using username Léna2).

For example, I successfully uploaded http://commons.wikimedia.beta.wmflabs.org/wiki/File:Test_file55.jpeg with no issue (not the username).


Can you retry your previous upload (maybe there was just a problem with beta that happened when you last tried). If it still fails, can you include the xml file you're using, and any information/settings about how you're using the tool?


As an aside, logically, it might be a good idea to have the directory use the user id, instead of the username.

Lena added a comment.Feb 20 2015, 9:33 AM

Will try tonight (in 10 hours) or Monday evening, really busy week and week-end :(

Lena added a comment.Feb 21 2015, 9:34 AM

Great news, it works \o/

Sorry to have bother you all and I hope it will not break down again :)

Lena closed this task as Resolved.Feb 21 2015, 9:35 AM