Page MenuHomePhabricator

Write maintenance script to make sure all Flow boards exist in page and revision table
Closed, ResolvedPublic2 Story Points

Description

If not, it should be created.

Problems with this may have been caused by T95581: Flow board creations do not create entry in core's page and revision tables or past issues (if any).

Related Objects

StatusAssignedTask
DeclinedNone
InvalidCapt_Swing
ResolvedDannyH
Resolvedmatthiasmullie
ResolvedCapt_Swing
Resolvedmatthiasmullie
Resolvedmatthiasmullie
Resolvedmatthiasmullie
ResolvedLegoktm
ResolvedDannyH
ResolvedLegoktm
ResolvedLegoktm
DuplicateNone
DuplicateNone
ResolvedSeb35
Resolvedmatthiasmullie
Resolved Mattflaschen-WMF

Event Timeline

EBernhardson triaged this task as High priority.Apr 10 2015, 5:44 PM
DannyH edited a custom field.Apr 13 2015, 6:59 PM
Mattflaschen-WMF closed this task as Resolved.Apr 22 2015, 5:41 PM
Mattflaschen-WMF claimed this task.

Since we're not 100% certain there are missing pages, we might want to run T96888: A14. Run maintenance/FlowUpdateWorkflowPageId.php in production first.
That script will output "Could not create title for %s at %s:%s" if there are any missing pages.
If there are missing pages (not unlikely), we can then still make this script.

Mattflaschen-WMF reopened this task as Open.Apr 22 2015, 7:17 PM
Mattflaschen-WMF removed Mattflaschen-WMF as the assignee of this task.

This is not resolved. I confused it with a similar but distinct script.

Change 206380 had a related patch set uploaded (by Matthias Mullie):
Create missing board pages

https://gerrit.wikimedia.org/r/206380

In order to move faster on what's blocking COOP, I decided to do this anyway.
While the work may not have been necessary, it was easy enough. If it turned out to be necessary (likely), it would have further delayed coop.

Change 206380 merged by jenkins-bot:
Create missing board pages

https://gerrit.wikimedia.org/r/206380

Change 206956 had a related patch set uploaded (by Mattflaschen):
Create missing board pages

https://gerrit.wikimedia.org/r/206956

Change 206957 had a related patch set uploaded (by Mattflaschen):
Create missing board pages

https://gerrit.wikimedia.org/r/206957

Change 206956 merged by jenkins-bot:
Create missing board pages

https://gerrit.wikimedia.org/r/206956

Change 206957 merged by jenkins-bot:
Create missing board pages

https://gerrit.wikimedia.org/r/206957