Page MenuHomePhabricator

Board Deletion Issues (affects Co-op)
Closed, ResolvedPublic

Description

As an Admin deleting a page with a Flow Board, I expect all the topics on the Flow Board to be deleted as well (T90969)

As an Admin who has deleted a Board, I expect to be able to inspect the deleted contents (T90972)

As an Editor who has contributed to anything in Flow Board, when that Board is deleted I expect all the contributions to end up in my "deleted contributions" log (T90973)


Trello card: 644kMu6Z

  • column: Send to Phabricator - Collaboration-Team board
  • labels: Engineering/QA (blue)

Related Objects

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 20 2015, 2:07 AM
DannyH triaged this task as Normal priority.Feb 23 2015, 11:10 PM

Old notes, should go to backlog.

Mattflaschen-WMF renamed this task from Board Deletion Issues to Board Deletion Issues (affects Co-Op).Feb 26 2015, 10:58 PM
Mattflaschen-WMF added a project: Co-op.
I_JethroBT renamed this task from Board Deletion Issues (affects Co-Op) to Board Deletion Issues (affects Co-op).Feb 26 2015, 11:03 PM
I_JethroBT moved this task from Backlog to Flow on the Co-op board.
Mattflaschen-WMF updated the task description. (Show Details)EditedFeb 26 2015, 11:29 PM

@Capt_Swing So, you can delete a board that uses the flow-board content model (I didn't check how $wgFlowOccupyPages affects this, but we're moving away from that and it doesn't affect Co-op), by explicitly adding action=delete to the URL.

However, the rest doesn't work yet.

@Mattflaschen. Thanks! I have confirmed that I can delete boards in this way on testwiki. As long as any enwiki admin can do this too, the lack of a delete button should not block the Co-op launch.

@Mattflaschen. Thanks! I have confirmed that I can delete boards in this way on testwiki. As long as any enwiki admin can do this too, the lack of a delete button should not block the Co-op launch.

You should check the subtasks too. Most importantly, deleting a board does not delete the topics or make them inaccessible. For now, you should delete all of the topics before deleting the board.

I_JethroBT added a comment.EditedFeb 28 2015, 1:57 AM

@Mattflaschen If topics can actually be deleted individually, that's fine. I can direct admins who are mentors to use this method rather than attempt to delete the entire page, which addresses the issue with T90969.

@Capt_Swing I agree with Matt that the blocking tasks above need to be addressed before Flow is implemented on the Co-op.

Mattflaschen-WMF added a comment.EditedFeb 28 2015, 4:40 AM

@Mattflaschen If topics can actually be deleted individually, that's fine.

They definitely can, but you have to use Flow's internal topic deletion mechanism. This is the only one exposed in the UI, but just in case, I've put up a patch to block the other one. See T91150: When using core's deletion interface (action=delete), appears to work but topics are not actually deleted .

@Capt_Swing I agree with Matt that the blocking tasks above need to be addressed before Flow is implemented on the Co-op.

I wasn't actually saying that all of them necessarily have to be addressed before Co-op. I just put this tracking task as a blocker because T89321: How to delete Flow boards (the task I merged in here) was a blocker for several Co-op tasks before.

Some are not as important in my opinion, and would not be blockers in my opinion. E.g. T90971: Unusable suggested message when deleting Flow boards is just about the default message; you can still choose a nice message.

In T90077#1075368, @Mattflaschen wrote:

@Mattflaschen If topics can actually be deleted individually, that's fine.

They definitely can, but you have to use Flow's internal topic deletion mechanism.

This is the one in the ... menu next to the topic title.

I've updated the blocking tasks based on what is needed inre: performing deletions to allow Flow to be used on the Co-op.

I added T90974: U3. Don't reuse board workflow when board is re-created back, since it's necessary to avoid old deleted topics coming back when you recreate a board.

What work needs to be done here?

None, it's done. However, there's at least one other issue that was deliberately not marked a blocker here, T90971: Unusable suggested message when deleting Flow boards.

Mattflaschen-WMF closed this task as Resolved.May 14 2015, 6:17 PM
Mattflaschen-WMF reopened this task as Open.
Mattflaschen-WMF assigned this task to matthiasmullie.
DannyH closed this task as Resolved.Jun 2 2015, 12:49 AM