Page MenuHomePhabricator

Convert Special:Tags to OOUI
Closed, ResolvedPublic

Description

Uses HTMLForm already.

Event Timeline

Florian created this task.Nov 4 2015, 5:29 PM
Florian raised the priority of this task from to Normal.
Florian updated the task description. (Show Details)
Florian added a project: UI-Standardization.
Dips03 added a subscriber: Dips03.Mar 12 2016, 8:59 AM
Dips03 removed a subscriber: Dips03.Mar 12 2016, 9:01 AM

Change 276954 had a related patch set uploaded (by Pankajeshkr):
Changed Special_Tags to OOui

https://gerrit.wikimedia.org/r/276954

Change 276957 had a related patch set uploaded (by Utk95):
Changed #$form = new HTMLForm to HTMLForm 'ooui'

https://gerrit.wikimedia.org/r/276957

Change 276951 had a related patch set uploaded (by 01tonythomas):
Change Special:Tags to OOUI

https://gerrit.wikimedia.org/r/276951

Change 276954 abandoned by Pankajeshkr:
Changed Special_Tags to OOui

https://gerrit.wikimedia.org/r/276954

Change 276970 had a related patch set uploaded (by 01tonythomas):
Change all HTMLforms on Special:Tags including delete and deactivate for ooui]

https://gerrit.wikimedia.org/r/276970

Change 276957 abandoned by Bartosz Dziewoński:
Changed #$form = new HTMLForm to HTMLForm 'ooui'

Reason:
Duplicate of https://gerrit.wikimedia.org/r/#/c/276951/

https://gerrit.wikimedia.org/r/276957

Remaining non-abandoned changes:

matmarex removed a subscriber: matmarex.Apr 4 2016, 1:48 PM

Possible Google-Code-In-2016 task ? To complete those changes ? @matmarex -- thinking of mentoring ? :D

I'm adding in the GCI tag and moving this to 'missing-mentors' there.

Wondering if @Florian or @Legoktm (once available) could imagine mentoring this in GCI...?

Change 276970 abandoned by Florianschmidtwelzow:
Change all HTMLforms on Special:Tags including delete and deactivate for ooui]

Reason:
See https://gerrit.wikimedia.org/r/#/c/276951/

https://gerrit.wikimedia.org/r/276970

Florian removed vaishali_jain as the assignee of this task.Jan 1 2017, 3:58 PM
Florian moved this task from Missing mentors to Imported in GCI Site on the Google-Code-In-2016 board.
Florian added a subscriber: vaishali_jain.

As the change https://gerrit.wikimedia.org/r/#/c/276951/2 is untouched since March last year, I unassign the task from @vaishali_jain and imported it as a GCI task (which I'll mentor): https://codein.withgoogle.com/dashboard/tasks/5836115925794816/

Change 330083 had a related patch set uploaded (by Awu42):
Converted Special:Tags to OOUI

https://gerrit.wikimedia.org/r/330083

Please provide a before/after screenshot!

Change 276951 abandoned by TTO:
Change Special:Tags to OOUI

Reason:
Done in https://gerrit.wikimedia.org/r/330083

https://gerrit.wikimedia.org/r/276951

Change 330083 merged by jenkins-bot:
Converted Special:Tags to OOUI

https://gerrit.wikimedia.org/r/330083

TTO closed this task as Resolved.Jan 3 2017, 9:39 AM
TTO assigned this task to Awu42.
TTO added a subscriber: TTO.

TheDJ added a subscriber: TheDJ.EditedJan 3 2017, 12:14 PM

I think we should move the "create a new tag" interface into a special /create subpage. The form has no direct connection with the primary function of the special page, which is to list the known tags and we already do so for /delete, activate and deactivate actions

I think we should move the "create a new tag" interface into a special /create subpage. The form has no direct connection with the primary function of the special page, which is to list the known tags and we already do so for /delete, activate and deactivate actions

I think this makes sense.