Page MenuHomePhabricator

Adding a link with an interwiki prefix in VE doesn't work
Closed, ResolvedPublic0 Estimated Story Points

Description

Adding a link with an interwiki prefix doesn't do what I expect it to do.

In the English Wikipedia I type :fr:ASCII in the link inspector, but what I actually get when I save is fr:ASCII. The software thinks that it's an interlanguage link rather than an inline interwiki link to an article in the French Wikipedia, and doesn't show it in the text.

The colon in the beginning must not be removed if it was typed by the editor.

Event Timeline

Amire80 created this task.Apr 25 2016, 1:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 25 2016, 1:13 PM

If you paste the full external link Parsoid will abbreviate it to an interwiki link. What could be improved is an interface for adding such links with autocomplete.

Jdforrester-WMF triaged this task as Low priority.Apr 26 2016, 7:10 PM
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF moved this task from To Triage to Freezer on the VisualEditor board.
Elitre added a subscriber: Elitre.Jun 13 2016, 7:04 AM

T95850 looks also related.

Gnom1 added a subscriber: Gnom1.Oct 22 2016, 9:30 PM
Gryllida added subscribers: Gryllida, Krenair, Framawiki.

Copied my comment from T188871 which is a duplicate of this task I think:

Yes, it would be nice to have autocomplete too for people who do not yet know the page name.

Suggested look and feel:

(I "stole" the dropdown appearance from https://stats.wikimedia.org/v2/#/all-projects .)

Deskana closed this task as Resolved.Mar 6 2018, 7:41 PM
Deskana claimed this task.
Deskana changed the point value for this task from 8 to 0.
Deskana added a subscriber: Deskana.

The original bug here was that writing :fr:ASCII into the link inspector gives you fr:ASCII instead of :fr:ASCII. I just tested this, and this bug appears to be fixed, so I'm closing as resolved.

@Gryllida What you're requesting seems to be a separate thing from this, since this was a bug report and you're making a feature request. It should probably be in a different task.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 6 2018, 7:41 PM
Elitre added a comment.Mar 8 2018, 6:08 PM

Maybe unmerge Gryllida's task and/or repurpose it?

I believe I reopened that, please do other necessary changes.