Page MenuHomePhabricator

While editing textarea gets empty
Closed, ResolvedPublic

Description

T135747 breaks text entry for wikEd users

in dewiki since about one hour (~ 2016-08-04T21:50:00 MESC ):

When I try to edit a page or a section the textarea get empty

the problem is reproducibel but not in every edit visible.

there is no problem if wikEd is turned on (with visible syntaxhighlight)

the problem is reproduceable at chrome and firefox.

Please unbrake this issue now!

Event Timeline

Boshomi created this task.Aug 4 2016, 8:43 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 4 2016, 8:43 PM
Boshomi updated the task description. (Show Details)Aug 4 2016, 8:52 PM

From the screenshot, it looks like you have a number of gadgets or user scripts enabled. Can you try disabling them all to see if that fixes the problem? If it doesn't, it's probably a MediaWiki issue. If it does, try enabling them back one-by-one to identify the problematic one.

I removed all the scripts
global.js
and common.js

, the problem is still here.

Steps:

  1. https://de.wikipedia.org/w/index.php?title=Basel&action=edit
  2. edit some text
  3. click into summary => textarea get empty
Aklapper renamed this task from massiv problem with textarea - while editing textarea get empty to While editing textarea gets empty.Aug 5 2016, 8:53 AM

Cannot reproduce the problem with the provided steps in Firefox 48 on Fedora.

@Boshomi: Do you know if anybody else has also faced this problem?

I removed all the scripts

How exactly?

@Boshomi: Please provide browser information and Wikimedia skin/theme information.

Schnark added a subscriber: Schnark.Aug 5 2016, 9:40 AM

This is also reported on https://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28technical%29#Firefox_bug_or_just_me.3F and https://de.wikipedia.org/wiki/Wikipedia:Fragen_zur_Wikipedia#Editorfehler_.3F

Additional information from there:

  • It has been reproduced in Firefox, Safari, Chrome and Edge, so it's not a browser issue.
  • When adding a section, the textfield sometimes behaves like it is readonly.
  • Reloading the page seems to fix the issue.
  • For some, even resizing the window fixes the issue.
  • Some users can reproduce the issue by just focusing the textfield and then focusing the input for the edit summary.
  • No error messages appear in the browser console.
Aklapper triaged this task as High priority.EditedAug 5 2016, 10:46 AM

T142180 might be the same problem, using Monobook skin.

Screenshot here looks like Vector skin?

Affecting me as well on enwp, edit page loads normally then all text disappears after a few seconds. I have not yet found a way to stop it happening. (Firefox 47 / opensuse 13.1 if relevant)

Affected at least 2 users on hr.wp also, Linux and Windows, Firefox.

This is crosswiki and cross-operating system problem, I guess JavaScript related.

A user that is impacted reports that if they log out the problem stops occurring - I've asked if they can try to isolate an account/gadget/script that is related.

https://en.wikipedia.org/wiki/Wikipedia:Village_pump_%28technical%29#Chrome_deletes_entire_edit_box_when_left-clicking_the_edit_summary

I have wikEd installed (https://en.wikipedia.org/wiki/User:Cacycle/wikEd_help). When it's installed but disabled (pencil on notepad icon toggles it on and off) the blanking problem occurs. When I enable it, no problems (a handful of times all OK so far).

Luke081515 added a subscriber: Luke081515.

Actually I can't reproduce it with vector nor monobook. I used an account without any scripts etc.

Xaosflux added a comment.EditedAug 5 2016, 6:49 PM

For anyone who is experiencing this problem - if you have installed any personal user scripts, please uninstall and try again. Note: root cause has not yet been identified, however if you can list any user script you removed that resolved your issue a common component may be able to be identified.

I have vector.

I think it is an issue of wikEd

After switch off WikEd in the preferences/gadget menue I could not reproduce the issue.

Turn wikEd on but switch off the wikEd-Menue the bug is reproduce-able.

The bug also occures if I turn off wikEd with the button top right of a page.

The bug does not occurs if wikEd Menue is visible.

on enwiki i saw a issue where the recent keyboard-strokes disappear and the courser get automaticly to the End of the Article.

greg added a subscriber: greg.Aug 5 2016, 8:24 PM

The same issue is also happening to me. I can recreate when signed-in to EN WP on Firefox, IE and Chrome. I cannot recreate the issue when not signed in. As mentioned by @Boshomi above, if I turn on wikEd the "blanking" does not occur. If I turn off wikEd again, the "blanking" behaviour does not occur in the same editing session. However, if I reload the page, or try and edit another page, the issue recurs.

The "blanking" behaviour occurs when the focus is removed from the main editing pane (for example if, after making an edit, I switch focus to the edit summary text box).

Intriguingly, if I make an edit, and then change focus to the edit summary pane, only the text I changed in the edit pane is undone/blanked. (Almost like an "undo" or page reload is triggered).

If I do not make any edit, and simply change the focus to the edit summary pane, the entire edit pane is blanked.

This issue started manifesting for me today Aug 5 at approx 13:00 UTC. It did not occur with edits I made last night Aug 4. at approx 19:00 UTC.

The issue started manifesting with whatever release contained the change which "split" the "your alerts" and "your notifications" widgets.

Note: To eliminate custom JS as a possible cause, I blanked my vector.js (https://en.wikipedia.org/w/index.php?title=User:Guliolopez/vector.js&action=history). However, I was able to recreate the issue after this change. So I don't think this is/was the issue. Happy to try other "process of elimination" tests if it will help with root cause. Is clearly a JS issue. *Something* is triggering a JS event which is blanking the edit pane/content. I find it interesting that it occurs consistently on multiple browser types (granted all largely webkit based). Am intrigued that this isn't affecting more editors (though perhaps it is and they aren't reporting). Otherwise perhaps others are using WikEd. I don't use WikEd. Although I have to now as otherwise I can't edit at all with this issue.

OK. Per my related comment on the EN WP Village Pump, I have resolved this issue by disabling the WikEd gadget ENTIRELY from my preferences. (If WikEd was turned off at the page level it didn't fix the issue. Not consistently at least. However, if I turn off WikEd *entirely* in prefs, the issue goes away.) I can no longer recreate the issue. As a workaround for other editors, I would recommend turning off WikEd in prefs. (If turning off the power at the socket doesn't work, turn off the power at the mains).

Intriguingly, if I make an edit, and then change focus to the edit summary pane, only the text I changed in the edit pane is undone/blanked. (Almost like an "undo" or page reload is triggered).

I still can't reproduce the original issue (even with wikEd enabled in preferences, but disabled using the icon), but I can sort of reproduce this.

With the following steps: [before you start: enable wikEd in preferences, disable it using the icon, refresh the page]

  1. Focus the textarea
  2. Switch wikEd on
  3. Switch wikEd off
  4. Focus the textarea
  5. Edit
  6. Focus the edit summary

After doing step 6, the content of the editing textarea is restored to what it was at step 1, losing anything I type in step 5.

I reverted my edit to the gadget in case that was causing issues.

Thanks to @AlexMonk-WMF

Now wikEd works fine.

@AlexMonk-WMF - was the change you made to the gadget local to dewiki only?

JJMC89 added a comment.Aug 6 2016, 2:39 AM

@AlexMonk-WMF - was the change you made to the gadget local to dewiki only?

The change and revert were at en:w:User:Cacycle/wikEd.js.

Xaosflux updated the task description. (Show Details)Aug 6 2016, 3:07 AM
Schnark closed this task as Resolved.Aug 6 2016, 8:06 AM
Schnark assigned this task to AlexMonk-WMF.

The revert to wikEd.js resolved the issue. If somebody still has problems, you should clear your cache to get the latest version of wikEd.js.

@Boshomi, @Rjwilmsi: I made a new edit to fix the original problem, this time hopefully not triggering this issue again. Can you confirm everything is working fine for you?

@AlexMonk-WMF Yes, working fine for me. Thanks.

@AlexMonk-WMF Yes it works fine. Thanks. I reported a performance issue with Chrome at task T142461

Thanks @Rjwilmsi and @Boshomi.
@Boshomi, I don't think tasks for that gadget have been moved to Phabricator by the wikEd devs?

Boshomi added a subscriber: Cacycle.Aug 9 2016, 1:38 PM

Ok, I don't know either. I changed the assingment to @Cacycle