Page MenuHomePhabricator

VE+NWE: Newarticletext into editintro
Closed, DeclinedPublic

Description

In T153579, @jeblad wrote:

A mysterious warning pops up during editing of sections at w:no:Wikipdia:Tinget. The text "1 varsel" is "1 warning". (Proper Norwegian would be "Ett varsel" (ie. spelled out numeral) but that would be another bug.)

On cswiki we deal with a similar problem. For OWE we have got a long intro when creating a non-existing page (take a look), but in NWE/VE that long text is transcluded into this small notice box (take a look).

Shouldn't this be in some form of editintro as it is in OWE?

PS: Is there a way how to make different MediaWiki:Newarticletext for OWE and VE/NWE? Is there a way how to hide the whole notice (e.g. by user script)

Event Timeline

Dvorapa created this task.Jan 14 2017, 12:35 PM

PS:

For general questions that are not feature requests or bug reports, https://www.mediawiki.org/wiki/2017_wikitext_editor/Feedback is recommended.

PS:

For general questions that are not feature requests or bug reports, https://www.mediawiki.org/wiki/2017_wikitext_editor/Feedback is recommended.

I'll try, thank you

What is the bug here? That the popup isn't wide enough?

What is the bug here? That the popup isn't wide enough?

Yes, cswiki's message does not fit into this small area, the area is both thin and short for our long, but necessary message.

More cswiki users complained (some already archived, latest e.g. there), that this notice obstructs and disturbs them.

From my point of view a solution could be one of these:

  1. Change size of this popup (automatically depending on the message size?) and possibly hide it by default (the warning triangle could be red to notice there is a warning not shown)
  2. Don't show the message in a popup, rather show it somewhere else (but where? above??)
  3. Create two different messages for VE and WE, for VE we'll try to fit into this area (this would be provisional and after conversion from OWE to NWE 1. or 2. must be chosen either)

The entire message fits easily on my laptop:

If you have a different font size/screen size/etc., or if there are multiple notices on the same page, then you can scroll down the box to read everything.

The entire message fits easily on my laptop:


If you have a different font size/screen size/etc., or if there are multiple notices on the same page, then you can scroll down the box to read everything.

  1. Some users complained this popup is disturbing. 2) You can scroll, but many important informations are hidden at first, this concept is not good for OWE's editintro at all. 3) There are many users, who don't browse Wikipedia in maximized window, see:

Jdforrester-WMF closed this task as Declined.Mar 14 2017, 7:15 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

The width of the edit notice panel is picked to support mobile users as well as desktop ones. If a wiki is writing lengthy messages into this feature (beware of banner blindness) that are so long that they don't "work" on mobile screens, then the problem is not with the panel.

I'd be happy to explore other options for making sure that users know what to do, but anything more than a few dozen words is almost certainly not the right answer.

Restricted Application added a subscriber: jhsoby. · View Herald TranscriptMar 14 2017, 7:15 PM

@Jdforrester-WMF: These are the informations on the Czech Wikipedia, which we want to preserve somehow and show when opening a red link:

  • There is no such article yet
  • New article can be written into this space and saved by top-right Save button
  • Mentions to this name in other articles could be found using search
  • This name could be found in wikidictionary
  • If you are a novice, there are some help pages
  • There is a sandbox for experiments
  • If you created this article, but it isn't there yet, it is caused by a cache
  • If you created this article, but it already isn't there, it could be deleted

Could you help our community to figure out some other solution?

I would suggest some form of modal dialog, like this one: