Page MenuHomePhabricator

License in Gallery view does not account for multiple (and sometime conflicting) licenses e.g. {{Licensed-PD-Art}} or {{Licensed-PD}}
Closed, ResolvedPublic

Description

If a file has multiple conflicting licenses (such as a licensed piece of art), the gallery may display only th eleast restrictive licnse, no matter if that license is applied only to the object 8artwork) or the digital reproduction. Sometimes an artist may relase their artwork under a license, but a photographer of that artwok can claim copyright of the photo (WMF has some opinions about faithful reproductions of 2D-works, but assuming that does not apply, such as with artworks with frames, or 3d objects such as the example below), this causes the app to not dispaly correct license information.

https://commons.wikimedia.org/wiki/File:Lincoln_statue.jpg on https://en.wikipedia.org/wiki/Talk:Fasces

Displays only a Public Domain markDisplays that the object (statue) is PD, but the image is cc-by-sa 3.0 / GFDL)

We could map common "license templates" such as {{Licensed-PD-Art}} or {{Licensed-PD}} in order to draw some metadata from them somehow, on how licenses are applied, until SDC General is a thing.

(As a sub-thing, we should also provde more licenses than one if multi-licensed)

iOS 10.2.1 (beta)
Build 1046

Event Timeline

Josve05a created this task.Jan 26 2017, 2:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 26 2017, 2:26 PM
Josve05a renamed this task from License in Gallery view does not account for e.g. {{Licensed-PD-Art}} or {{Licensed-PD}} to License in Gallery view does not account for multiple (and sometime conflicting) licenses e.g. {{Licensed-PD-Art}} or {{Licensed-PD}}.Jan 26 2017, 2:29 PM
Josve05a added a project: User-Josve05a.
Josve05a updated the task description. (Show Details)
Josve05a updated the task description. (Show Details)
Josve05a updated the task description. (Show Details)Jan 26 2017, 2:34 PM
JMinor triaged this task as Low priority.Jan 30 2017, 10:56 PM
JMinor moved this task from Needs Triage to Product Backlog on the Wikipedia-iOS-App-Backlog board.
JMinor added a subscriber: JMinor.

We could map common "license templates" such as {{Licensed-PD-Art}} or {{Licensed-PD}} in order to draw some metadata from them somehow, on how licenses are applied, until Structured-Multimedia-Data is a thing.

Does such a map exist or would we have to create it? Would you or someone from the Commons community be able to create such a map or would it need to come from an RFC or wiki discussion?

Same thing with MediaViewer. I'm guessing you hshare some repository code or something.., so adding them to this task.

We could map common "license templates" such as {{Licensed-PD-Art}} or {{Licensed-PD}} in order to draw some metadata from them somehow, on how licenses are applied, until Structured-Multimedia-Data is a thing.

Does such a map exist or would we have to create it? Would you or someone from the Commons community be able to create such a map or would it need to come from an RFC or wiki discussion?

Don't think it exists, since MediaViewer also have this issue...

Restricted Application added a project: Wikidata. · View Herald TranscriptJan 31 2017, 12:10 PM
FDMS added a subscriber: FDMS.Jan 31 2017, 6:14 PM

Sounds related to (if not a duplicate of) T89692.

Tgr added a subscriber: Tgr.Jan 31 2017, 9:51 PM

Sounds related to (if not a duplicate of) T89692.

Indeed, it's a consequence of that issue (which is stalled due to lack of community interest).

phuedx moved this task from Incoming to 2014-15 Q4 on the Readers-Web-Backlog board.
Josve05a moved this task from Backlog to iOS App on the User-Josve05a board.Feb 5 2017, 2:51 PM
Restricted Application added a subscriber: PokestarFan. · View Herald TranscriptAug 7 2017, 5:47 PM
Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.Dec 18 2017, 3:26 PM
LGoto closed this task as Resolved.Mar 26 2019, 9:25 PM
LGoto claimed this task.
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMar 26 2019, 9:25 PM