Page MenuHomePhabricator

Adding fonts for Church Slavonic language in ULS
Closed, ResolvedPublic

Description

Please add fonts for Church Slavonic language in ULS (files in attachment).

The main font is Ponomar Unicode (previously called Hirmos Ponomar) for typesetting Synodal Church Slavonic (that is, Church Slavonic used in modern liturgical texts of the Russian Orthodox Church). It may also be used to typeset liturgical texts in Romanian (Moldovan) Cyrillic, Aleut and Sakha (Yakut).

Fedorovsk Unicode is designed to mimic the typeface used by Ivan Fedorov, who produced some of the first printed books in Moscow. It is intended primarily for reproducing publications from that era, either in an academic setting, or as modern Old Rite liturgical texts.

Monomakh Unicode is a Cyrillic font implemented in a mixed ustav/poluustav style and intended to cover needs of researches dealing with Slavic history and philology. It also provides Latin characters in a similar typeface, which is useful for working with multilingual academic editions.

Menaion Unicode provides both Cyrillic and Glagolitic characters and is intended for representing text from Ustav-era Church Slavonic manuscripts.

All fonts are free software, dual-licensed under the GNU General Public License, version 3.0, or the SIL Open Font License, version 1.1, at your choosing.

Discussion

Here.

Details

Related Gerrit Patches:
mediawiki/extensions/UniversalLanguageSelector : masterAdd fonts for Church Slavonic

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 31 2017, 7:24 PM
Iniquity added a comment.EditedJun 13 2017, 6:22 PM

Any progress here?
@Amire80 can you help?

Iniquity updated the task description. (Show Details)Jun 13 2017, 6:25 PM
Iniquity added a subscriber: Amire80.

Please! It's really useful not only for Russian but for Ukrainian also. In our languages Church Slavonic texts usually citing in modern texts without additional styling, we distinguish modern text from cites by font only. It's common tradition since beginning on 18 century while modern font (гражданский шрифт) was designed. So now, without these fonts we are not able made adequate copies of many sources in Ukrainian and Russian Wikisources and we do not able made Church Slavonic (i. e. Church and all pre-18 century) cities according to our typographic traditions in Russian, Ukrainian and possible both Belarus Wikipedias.

FYI: If you'd like to contact ULS' maintainers, see the "Contact us" section on https://www.mediawiki.org/wiki/Wikimedia_Language_engineering#Contact_us

Madvin added a subscriber: Madvin.Jun 26 2017, 11:58 AM
NickK awarded a token.Jun 26 2017, 8:02 PM
ReAl awarded a token.Jul 1 2017, 5:08 PM
ReAl added a subscriber: ReAl.Jul 1 2017, 5:10 PM
santhosh claimed this task.Apr 1 2019, 7:39 PM

Change 500541 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/UniversalLanguageSelector@master] Add fonts for Church Slavonic

https://gerrit.wikimedia.org/r/500541

Apologies for delay in addressing this. UniversalLanguageSelector project is under maintanance so we could not give much attention.

ULS font settings:

Rendering test:

This is amazing, thank you!
Will this also works on Wikisource by T219065?

I did not quite understand. Now fonts will be downloaded automatically for all readers? Or will each reader required to register in WMF, and then manually enable font autodownloading in the ULS interface (by clicking on the gear icon near the list of interwiki)?

@Vladis13 Refer https://en.wikisource.org/wiki/Template:Blackletter and https://en.wikisource.org/wiki/Template:ULS for how this feature is used elsewhere.

In a wiki, ULS webfonts feature can be enabled by default or leave that to user to choose from gear icon. en.wikisource.org has this feature enabled by default. ru.wikisource.org has the feature disabled by default, so users has to choose the gear icon method. But if community is ok to enable this by default, file a ticket and we can enable like en.wikisource.org.

Ok, thank you again!

Change 500541 merged by jenkins-bot:
[mediawiki/extensions/UniversalLanguageSelector@master] Add fonts for Church Slavonic

https://gerrit.wikimedia.org/r/500541

UniversalLanguageSelector project is under maintanance so we could not give much attention.

@santhosh: That sentence implies that when you maintain something you do not give it much attention... :)

Checked in enwiki and wnwikisource (wmf.24). There is still some incomplete rendering for cu lang option. @santhosh - something else should be done in terms of downloading fonts or something?


@Etonkovidova we have not mapped these fonts to cu by default. So people need to choose one of these other than "System font" option.

can be verified at these test pages:

https://ru.wikipedia.org/w/extensions/UniversalLanguageSelector/tests/webfonts.html
and https://ru.wikipedia.org/w/extensions/UniversalLanguageSelector/tests/all-fonts.html

Etonkovidova closed this task as Resolved.Apr 12 2019, 9:03 PM

Thx, @santhosh - yes, everything is in place.