Page MenuHomePhabricator

Unexpected general module 'ext.math.scripts' in styles queue.
Closed, ResolvedPublic

Description

I can reproduce this when enabling verbose logging (X-Wikimedia-Debug) on wikidata.org

DEBUGresourceloadermwdebug1002wikidatawikiUnexpected general module "ext.math.scripts" in styles queue.

It seems this module doesn't seem to need any kind of migration. It contains only a javascript file and it being queued via addModuleStyles() is entirely a no-op.

		"ext.math.scripts": {
			"scripts": "ext.math.js"
		},

Event Timeline

Krinkle created this task.Feb 17 2017, 1:02 AM

Change 338472 had a related patch set uploaded (by Krinkle):
Remove 'ext.math.scripts' from styles queue on wikidata

https://gerrit.wikimedia.org/r/338472

Change 338472 merged by jenkins-bot:
Remove 'ext.math.scripts' from styles queue on wikidata

https://gerrit.wikimedia.org/r/338472

Krinkle closed this task as Resolved.Feb 24 2017, 11:13 PM
Krinkle claimed this task.
Krinkle reopened this task as Open.EditedMay 11 2017, 11:46 PM

Change 338472 merged by jenkins-bot:
Remove 'ext.math.scripts' from styles queue on wikidata
https://gerrit.wikimedia.org/r/338472

This warning is back in the logs:

Unexpected general module "ext.math.scripts" in styles queue.

  • mwversion: 1.30.0-wmf.1
  • wiki: enwiki

Triggered on various en.wikipedia.org page views.

Krinkle removed Krinkle as the assignee of this task.May 11 2017, 11:46 PM
Krinkle raised the priority of this task from Normal to High.

ok. Now I understand the issue. The js script has been removed from the wikidata UI but not from the normal mediawiki ui.

It might also be caused by the wikibase client...

Change 355793 had a related patch set uploaded (by Physikerwelt; owner: Physikerwelt):
[mediawiki/extensions/Math@master] Remove math script from Wikibase client styles queue

https://gerrit.wikimedia.org/r/355793

Change 355793 merged by jenkins-bot:
[mediawiki/extensions/Math@master] Remove math script from Wikibase client styles queue

https://gerrit.wikimedia.org/r/355793

Krinkle closed this task as Resolved.Jun 2 2017, 2:35 PM

Thanks!