Page MenuHomePhabricator

Set the default for Special:Notifications to "Unread" (at least if there are any unread messages)
Closed, ResolvedPublic

Description

Problem:

I get a lot of notifications. At the moment, I've got 65 unread 'inbox' items and 4 unread 'bell' items. The little flyout can't handle that volume, so I've given up on it, and I go to [[Special:Notifications]] a lot – multiple times per day. And every single time I load that page, the first thing I have to do is to click over to the 'Unread' tab and wait for it to filter the results – multiple times per day.

I want that page to default to the 'Unread' tab. I don't care whether it's done automatically for everyone or if it remembers the setting that I used the last time or if I have to manually tick a box in Special:Preferences. I just don't want to have to click that on tab – multiple times per day, every day, for the rest of my wiki-life.

The problem is obvious at my volume, but the automatic focus on unread messages would probably be helpful to anyone with more than one or two unread notifications.

Event Timeline

Trizek-WMF added a comment.EditedApr 14 2017, 10:03 AM

Are those notifications local or cross wiki ones? Cross-wiki notifications are not included in the "Unread" tab.

Proposal: let's just make it so that if you have Unread notifications, the page will be set to Unread on load--but only for the current wiki.

I think this will be an improvement. And if it's not, then we can try something else next time.

Users reach the notification page through an "All notifications" option in the unread-focused notification flyout panel. This is why we were inclined to show all notifications by default.

Having said that, if we think that a different view is more useful, I think we can adjust that since the control to reach all notifications from the page seem discoverable. I think it is important to avoid cases where we lead users to an empty view for no reason, so Joe proposal makes perfect sense: direct users to the unread view only when there are unread notifications in the current wiki.

Also, a clarification: cross-wiki notifications are accessible from the "unread" tab. What was limited was to show all the read notifications from different wikis. So it is the "read" tab the one without cross-wiki notifications.

Change 348940 had a related patch set uploaded (by Sbisson):
[mediawiki/extensions/Echo@master] Special:Notifications show unread by default if there's unread notifications

https://gerrit.wikimedia.org/r/348940

Change 348940 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Special:Notifications show unread by default if there's unread notifications

https://gerrit.wikimedia.org/r/348940

Checked in betalabs

  • 'Unread' is a default filter on Special:Notification
  • 'Unread' filter will be also displayed when the link for cross-wiki notifications (in the left panel) will be clicked
  • When there are zero notifications in a current wiki, 'All' will be default filter.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Apr 26 2017, 1:44 AM