Page MenuHomePhabricator

Regression: Fix config to disable related pages where it's not wanted
Closed, ResolvedPublic

Description

The fix for T162213 accidentally enabled related pages for projects on Thursday 13th 4PM PST that didn't want to. The issue was promptly identified but we were unable to address it until the next SWAT window. Due to the datacenter switch-over, this is blocked until the week of the 24th.

Acceptance Criteria:

  • Remove Related Pages from German and Russian wikipedias

Testing Criteria:

  1. Visit the mobile website for Russian Wikipedia any day after April 13
  2. Select any article
  3. Scroll to the bottom of the article and ensure no "related pages" section appears
  4. Repeat the above for German wikipedia

  1. Visit the mobile website for English Wikipedia any day after April 13
  2. Select any article
  3. Scroll to the bottom of the article and ensure "related pages" section appears
  4. Repeat the above for Hebrew wikipedia

Details

Event Timeline

Change 348472 had a related patch set uploaded (by Jdlrobson):
[operations/mediawiki-config@master] Correctly enforce config for related pages

https://gerrit.wikimedia.org/r/348472

Restricted Application added a subscriber: Dereckson. · View Herald TranscriptApr 17 2017, 3:25 PM
ovasileva updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)Apr 17 2017, 4:41 PM
ovasileva edited projects, added Reading-Web-Sprint-96; removed Reading-Web-Sprint-95.
ovasileva moved this task from 2016-17 Q4 to Upcoming on the Readers-Web-Backlog board.

Discussed in standup: probably don't need to story-point this because it will just go in with a bunch of other swat'd tasks, and the estimate-able work is in the swat and not the content.

Jdlrobson moved this task from Doing to Needs Code Review on the Reading-Web-Sprint-96 board.

Change 348472 merged by jenkins-bot:
[operations/mediawiki-config@master] Correctly enforce config for related pages

https://gerrit.wikimedia.org/r/348472

Mentioned in SAL (#wikimedia-operations) [2017-04-24T23:41:51Z] <twentyafterfour@naos> Synchronized wmf-config/: deploy https://gerrit.wikimedia.org/r/#/c/348472/ refs T163114 (duration: 01m 05s)

Jdlrobson added a subscriber: greg.

The SWAT didn't help. I'm not sure what the config is doing but it's not behaving how I'd expect it

wmgRelatedArticlesFooterWhitelistedSkins and thus wgRelatedArticlesFooterWhitelistedSkins should be defined to an empty list for anything in the dblist related-articles-footer-blacklisted-skins (ruwiki and dewiki)

Instead of this dewiki and ruwiki are defaulting to what's in extension.json which is ['minerva']

@greg who's the best person to talk to to understand how the config is actually working? We've got two communities who are getting a feature they don't want so I'm quite keen to remedy this asap, but I have no idea how :-(

greg added a comment.Apr 25 2017, 9:24 PM

@Jdlrobson come to -releng or -operations, mostly.

Looks like we may have a lead :) T126306

T142663 could also be causing this problem.

Change 350459 had a related patch set uploaded (by Jdlrobson):
[operations/mediawiki-config@master] Workaround issue of overriding whitelist config variable

https://gerrit.wikimedia.org/r/350459

Tgr added a subscriber: Tgr.Apr 26 2017, 6:03 PM

Looks like we may have a lead :) T126306

That affects changes to the private repo only. There are not symlinks involved here.

The problem is probably that both default and related-articles-footer-blacklisted-skins match and they are either merged or only the first one is used, I don't remember which. InitializeSettings should really be documented somewhere.

Change 350459 merged by jenkins-bot:
[operations/mediawiki-config@master] Workaround issue of overriding whitelist config variable

https://gerrit.wikimedia.org/r/350459

Mentioned in SAL (#wikimedia-operations) [2017-04-26T18:58:35Z] <thcipriani@naos> Synchronized wmf-config/CommonSettings.php: SWAT: [[gerrit:350459|Workaround issue of overriding whitelist config variable]] T163114 (duration: 00m 53s)

Jdlrobson moved this task from Blocked Externally to Needs QA on the Reading-Web-Sprint-96 board.
Jdlrobson added subscribers: ABorbaWMF, Reedy.

@ABorbaWMF Can you run through the tests again?

@Reedy found a workaround solution and T142663 is the bad guy here.

Ok, tested on a variety of browsers and devices.

Related pages do not appear on Russian and German Wikipedias.

Related pages do appear on English and Hebrew Wikipedias.

Jdlrobson closed this task as Resolved.Apr 27 2017, 10:16 PM

Signing off