Page MenuHomePhabricator

Logo for sr.m.wikipedia.org
Closed, ResolvedPublic1 Story Points

Details

Related Gerrit Patches:
operations/mediawiki-config : masterCompress srlogo for Wikipedia
operations/mediawiki-config : masterLogo changes for various wiki projects
operations/mediawiki-config : masterUpdate logo and dimensions for SR wordmark
operations/mediawiki-config : masterAdd Wikipedia wordmark in Serbian/Macedonian

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Obsuser triaged this task as Medium priority.May 20 2017, 3:33 PM

Change 355625 had a related patch set uploaded (by Dereckson; owner: Dereckson):
[operations/mediawiki-config@master] Add Wikipedia wordmark in Serbian

https://gerrit.wikimedia.org/r/355625

@Obsuser Per https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes next step is to discuss this upcoming change with your local wiki community. For example, you can use the village pump.

@Zoranzoki21 was concerned this procedure isn't convenient for small, non controversial changes. A formal RFC isn't required from our point of view, it's up to the wiki to decide how they want do discuss such changes. So perhaps should you discuss on your wiki a lightweight procedure for smallest changes than a formal RFC if you've the feeling it's currently required?

@dungodung or @Milicevic01 can help if you need assistance for that.

Jdlrobson added subscribers: Nirzar, Jdlrobson.

There's no need for an RFC here.
Let me ping @Nirzar and check the logo is suitable for this usage.

We've a procedure requiring a notification to the wiki, so contributors know what's happening.

The Wikimedia Foundation pledged to adhere more to these procedures to avoid "surprise feature deployment" after the issues raised by the reception of MultimediaViewer by the German Wikipedia Community (the 'superprotect' case).

So, of course here a formal RFC isn't required, but some notification to the village pump or any appropriate place is.

No procedure is needed here. We've already done similar config changes for other projects. This is just switching a logo which is currently localised to English to a Serbian logo. Nothing controversial there, its common sense and MultimediaViewer has nothing to do with this.

A notification went out when we did the new header design which was the big radical change. I consider this just a follow up to that work.

Serbian:


existing Japanese:

Obsuser added a comment.EditedMay 25 2017, 5:32 PM

I have just started a needed formal voting, so we can we wait seven days for it to end or wait for five or ten support votes and then apply.

Also, someone should protect the file on Commons, as it is done for original/English version.

You might want to check grey shades, in order to have proper color; you have letters, so if you have SVG original text form it would be best only to retype so "ВИКИПЕДИЈА" is written (or compare SVGs)...

Jdlrobson added a comment.EditedMay 25 2017, 5:33 PM

@Nirzar this is is how it would look:


Okay?

Honestly, a vote for this is a little wasteful imo. We are committed to localisation across our projects and I'm not sure why the Serbian community would want a logo localised to English.

@Obsuser the file is copied locally so no need to protect it on Commons so all we'd need to do is SWAT the associated change.

I beg to differ. In the past, such notifications allowed to:

  • Notice a typo
  • Start a discussion to transliterate differently the project names
  • Notice the SVG rendering can be optimized
  • Start a discussion for a better font more convenient

The fact you didn't respect the procedures in the past.

Please also note the cost of notification on the village pump is really low. We're here discussing for ONE LINE on the village pump. Something like "I prepared https://commons.wikimedia.org/wiki/File:Wikipedia_wordmark_sr.svg for mobile UI, is that convenient?"

I have just started a needed formal voting, so we can we wait seven days for it to end or wait for five or ten support votes and then apply.

Thanks for this move. Note we all agreed a simpler procedure than a formal voting would have been enough.

Also, someone should protect the file on Commons, as it is done for original/English version.

Sure, done (log entry).

Dereckson updated the task description. (Show Details)May 25 2017, 5:36 PM

@Dereckson we're going to have to agree to disagree here. cc @CKoerner_WMF this seems like a bad use of volunteers time.

So, there are here two things a little mixed:

  • product requests, like localisation, code shipped in a Discovery extension: you can of course for these accept such requests as you wish, following the procedures you wish, and to minimize volunteer time is probably a good goal here
  • configuration requests, asking to the communities a system administrator updates the configuration at the request of a wiki, for which we've prepared a procedure to discuss every change on wiki before request it.

It could indeed be a burden for wikis without a lot of users, or for trivial changes, so in 2012 we advertised the process could be as lightweight as wiki wants: just a small message on the village pump without any objection or some "I agree, good idea" could be considered as sufficient. This procedure is documented at https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes.

ovasileva set the point value for this task to 1.May 30 2017, 4:39 PM

The RFC has 5 yes.
@Nirzar needs to approve this logo before we enable it
We may also want to add this to Macedonian wiki.

I'm catching up after the hackathon in Vienna and a personal holiday, so apologies for the delay.

Let me make sure I understand this correctly.

  1. The Serbian community noticed the wordmark for the project wasn't translated.
  2. They created a discussion to bring consensus
  3. This task tracks the request and the work to carry it out

I think there's some confusion on what it means to bring forth an request for comment and how serious that is. The phrase 'Rfc' has an unfortunate reputation of being used by communities in times of unrest and frustration. This community isn't upset, the request is easily well supported by the community, and the process/technical nature of the work is straight forward.

So this is what it should be like! :)

While this is a relatively small configuration change, which I doesn't necessitate a formal "big" Rfc process, it's still welcomed by everyone involved to go through the agreed upon steps to make sure nothing is missed. The prerogative is in the individual communities hand on how to handle gaining consensus - as big or as small as they'd like.

I think it's a fine thing to see folks at the WMF respond warmly to such requests, given that we're localizing the string retroactively. :)

They created a discussion to bring consensus

This isn't quite what happened. They were directed to write an RFC because of the policy at https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes.

To be clear I wasn't saying that RFC's were bad, but here it feels like unnecessary bureaucracy. This is my concern. I don't want us to have to write RFCs to change every logo in our projects - I'd argue that doesn't scale (since we have so many) and it might put projects/us off from doing that altogether.

I'd ask that we relax this policy of having RFCs for all config changes for only config changes where guidance is needed. There are no clear cut rules here but here it feels unnecessary.

Notice a typo / Start a discussion to transliterate differently the project names / Notice the SVG rendering can be optimized / Start a discussion for a better font more convenient

These can all be done retroactively or as part of the code review process. We work in an agile way, and I'd argue it's more productive in this particular example for @Obsuser to act as the representative of Serbian Wikipedia. The RFC arguably doesn't help us with any of these issues.

@Obsuser since the RFC has 5 'yes' votes I will deploy this today. If you can confirm the fix tomorrow that would be splendid.

Change 355625 merged by jenkins-bot:
[operations/mediawiki-config@master] Add Wikipedia wordmark in Serbian/Macedonian

https://gerrit.wikimedia.org/r/355625

Jdlrobson reassigned this task from Dereckson to ovasileva.May 30 2017, 11:10 PM
Jdlrobson removed a project: Patch-For-Review.
Jdlrobson added a subscriber: Dereckson.

yours to sign off...

ovasileva closed this task as Resolved.May 31 2017, 11:02 AM

looks good, confirmed on srwiki and mkwiki

Why it is smaller than en.wiki and ru.wiki logos? Was it intentional or there is some mistake?

Sorry I was away, to fix the sizing issue.

width="122px" height="22px"

Not a problem; however, it is still the same – smaller one...

ovasileva reopened this task as Open.Jun 8 2017, 11:16 AM

moving to needs more work for the styling change

ovasileva removed ovasileva as the assignee of this task.Jun 8 2017, 12:04 PM
ovasileva added a subscriber: ovasileva.
Jdlrobson claimed this task.Jun 8 2017, 3:57 PM

Change 357848 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Update logo and dimensions for SR wordmark

https://gerrit.wikimedia.org/r/357848

On swat calendar for today (4pm PST).

Change 357848 merged by jenkins-bot:
[operations/mediawiki-config@master] Update logo and dimensions for SR wordmark

https://gerrit.wikimedia.org/r/357848

Nirzar closed this task as Resolved.Jun 12 2017, 1:37 AM
Obsuser reopened this task as Open.Jul 6 2017, 12:03 AM

I reopened this task because color seems to be lighter grey than it is for English version of mobile Wikipedia logo.

Also, centering of the logo is not the same; it can be seen on the upper logo, the one left to the search bar, but also (even better) when one scrolls all the way down and swaps browser tabs between sr and en version (popping can be noticed, due to different height).

Btw, Terms of Use are missing too, don't know why...

I reopened this task because color seems to be lighter grey than it is for English version of mobile Wikipedia logo.

This is my fault :( I picked the wrong color from Sketch. My personal color management has gone haywire and I need to sort it out.

Apologies for having to redeploy this.

Fixed SVG

@Obsuser

Also, centering of the logo is not the same;

This is due to the descender in the logos. this can be fixed with commons.css on sr wiki. you can get in touch with the admin. it's 2 lines of code. we can't change it in main config because it will mess up all other logos. this is a sr specific issue.

Add following code to commons.css on sr.wikipedia.org It should fix the alignment.

.header .branding-box h1 img {
    top: 2px;
    position: relative;
}

The color will get fixed with new SVG

Add following code to commons.css on sr.wikipedia.org It should fix the alignment.

.header .branding-box h1 img {
    top: 2px;
    position: relative;
}

I added this code to common.css now.

not seeing it yet :(

cacheing issue?

Please don't edit Common.css. It doesn't run on the mobile site and won't help this problem. We'll fix both issues next week in a swat deploy.

Change 364241 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Logo changes for various wiki projects

https://gerrit.wikimedia.org/r/364241

Change 364241 merged by jenkins-bot:
[operations/mediawiki-config@master] Logo changes for various wiki projects

https://gerrit.wikimedia.org/r/364241

Mentioned in SAL (#wikimedia-operations) [2017-07-10T19:07:53Z] <niharika29@tin> Synchronized static/images/mobile/: Logo changes for various wiki projects [mediawiki-config] - https://gerrit.wikimedia.org/r/364241 (https://phabricator.wikimedia.org/T165896) (duration: 00m 20s)

Mentioned in SAL (#wikimedia-operations) [2017-07-10T19:09:39Z] <niharika29@tin> Synchronized wmf-config/: Stop disabling MFTidyMobileViewSections (T168671) and Logo changes for various wiki projects (T165896) (duration: 00m 21s)

Change 364269 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Compress srlogo for Wikipedia

https://gerrit.wikimedia.org/r/364269

Change 364269 merged by jenkins-bot:
[operations/mediawiki-config@master] Compress srlogo for Wikipedia

https://gerrit.wikimedia.org/r/364269

Mentioned in SAL (#wikimedia-operations) [2017-07-10T23:08:42Z] <thcipriani@tin> Synchronized static/images/mobile/copyright/wikipedia-wordmark-sr.svg: SWAT [[gerrit:364269|Compress srlogo for Wikipedia]] T165896 (duration: 00m 43s)

Nirzar closed this task as Resolved.Jul 10 2017, 11:09 PM