Page MenuHomePhabricator

REGRESSION - Option to suppress user accounts on blocks (hideuser) disappeared after migrating to OOjs UI
Closed, ResolvedPublic

Description

Per title, caused by T107036. Similar to what happened on T171405. Please fix. Thank you.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 7 2017, 9:43 PM
MarcoAurelio triaged this task as Unbreak Now! priority.Oct 7 2017, 9:46 PM

Tagging as UBN due to the current problem of not being able to suppress user accounts with abusive usernames or private information. I'd also suggest that the fix be backported to the current wmf MW branch as soon as possible so we can recover this function. Thank you.

Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptOct 7 2017, 9:46 PM
Reedy updated the task description. (Show Details)Oct 7 2017, 10:01 PM
Reedy added subscribers: Ladsgroup, matmarex.
Reedy added a subscriber: Reedy.Oct 7 2017, 10:08 PM

Do you want it reverting out of .2?

Not sure what do you mean @Reedy - In case I was not clear I think we need to fix this in master and after that patch the current MW branch we're using on WMF projects to recover the function as soon as this is repaired. Does that make sense? Regards.

Reedy added a comment.Oct 7 2017, 10:11 PM

Not sure what do you mean @Reedy - In case I was not clear I think we need to fix this in master and after that patch the current MW branch we're using on WMF projects to recover the function as soon as this is repaired. Does that make sense? Regards.

Yes. But I'm not the right person to be able to do that, and I don't know when someone that is will be available (it is a weekend).

So hence, offering to revert it out of the deployment branch, so the feature works, until we get a fix, and it can go out again with .3

If you don't think that's needed, then the bug probably isn't UBN

@Reedy IMHO it is UBN as we're now exposed to not being able to remove abusive usernames when blocking them (if developers disagree, feel free to readjust the priority). OOJS UI conversions are purely a design change that IMHO should not take over when a function that has been working as of now and that operates in the area of project privacy has been broken by the change. That said, I'd hate to request to "ruin" Amir's work, though if there's no option... I'd rather avoid not being able not to suppress accounts for the whole weekend... Your call. Thanks.

Reedy added a comment.Oct 7 2017, 10:25 PM

@Reedy IMHO it is UBN as we're now exposed to not being able to remove abusive usernames when blocking them (if developers disagree, feel free to readjust the priority). OOJS UI conversions are purely a design change that IMHO should not take over when a function that has been working as of now and that operates in the area of project privacy has been broken by the change. That said, I'd hate to request to "ruin" Amir's work, though if there's no option... I'd rather avoid not being able not to suppress accounts for the whole weekend... Your call. Thanks.

It's not nice, but it's how things are. If something gets through CR, and it's broken, especially in a major way, it can and should be reverted. It's a well understood rule.

There's no reason to revert out of master yet, I'll just revert, and cherry pick the reverts to the deployment branch

DoRD added a subscriber: DoRD.Oct 7 2017, 10:25 PM

Change 383008 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@master] Revert "SpecialBlock: Tweaks for OOUI HTMLForm"

https://gerrit.wikimedia.org/r/383008

Change 383009 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@master] Revert "SpecialBlock: Switch to OOUI form"

https://gerrit.wikimedia.org/r/383009

Change 383010 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@wmf/1.31.0-wmf.2] Revert "SpecialBlock: Tweaks for OOUI HTMLForm"

https://gerrit.wikimedia.org/r/383010

Change 383011 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@wmf/1.31.0-wmf.2] Revert "SpecialBlock: Switch to OOUI form"

https://gerrit.wikimedia.org/r/383011

Thanks @Reedy -- I'm going to sleep now so I won't be able to report if the reverts have brought the feature back. If other stewards/oversighters (or you should you have access) can check that it'd be appreciated. I'll ping the stewards' list so at least one of us can stay around and see if everything works as expected.

Change 383010 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.2] Revert "SpecialBlock: Tweaks for OOUI HTMLForm"

https://gerrit.wikimedia.org/r/383010

Change 383011 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.2] Revert "SpecialBlock: Switch to OOUI form"

https://gerrit.wikimedia.org/r/383011

Mentioned in SAL (#wikimedia-operations) [2017-10-07T22:44:55Z] <reedy@tin> Synchronized php-1.31.0-wmf.2/includes/specials/SpecialBlock.php: T177705 (duration: 00m 49s)

Mentioned in SAL (#wikimedia-operations) [2017-10-07T22:46:09Z] <reedy@tin> Synchronized php-1.31.0-wmf.2/resources/: T177705 (duration: 00m 48s)

Reedy lowered the priority of this task from Unbreak Now! to High.Oct 7 2017, 10:47 PM

Fixed in deployment. Not running scap at this time of night for one message. Should hopefully get fixed in master before .3 is cut

"blockip-legend": "Block user",
Volker_E renamed this task from REGRESSION - Option to suppress user accounts on blocks (hideuser) disappeared after migrating to oojs UI to REGRESSION - Option to suppress user accounts on blocks (hideuser) disappeared after migrating to OOjs UI.Oct 7 2017, 11:12 PM
DoRD added a comment.EditedOct 8 2017, 1:47 AM

Even though the format has been rolled back on enwiki, the suppress option is still not appearing. For me, it appears very briefly, but then disappears. (Firefox 56, MacOS 10.13, cache cleared, etc.) EDIT: Never mind, I was reminded that the block length needs to be set to indefinite for this to work.

Teles added a subscriber: Teles.Oct 8 2017, 4:53 AM
Stryn added a subscriber: Stryn.Oct 8 2017, 10:30 AM

With multiple changes to this interface occurring, a new bug may be related and is reported in T177728.

Vituzzu added a subscriber: Vituzzu.Oct 9 2017, 9:53 AM

"blockip-legend" is no longer localized, at least for Italian

Weird. I've tested on the Beta Cluster this, which was not rolled-back as it runs in master, and the option appears when selecting an "infinite" expiry time. I did that too on Production but it didn't worked back then when I reported this. Maybe this can be included again in the next MediaWiki train.

Reedy added a comment.Oct 9 2017, 12:09 PM

With multiple changes to this interface occurring, a new bug may be related and is reported in T177728.

"blockip-legend" is no longer localized, at least for Italian

Same issue. Scap wasn't run (purposely). The messages will have presumably been deleted from other languages too, so the revert cherry pick wouldn't bring them back to the branch anyway.

Hopefully it's short lived, and gets fixed properly anyway, so we don't need the message

Mentioned in SAL (#wikimedia-releng) [2017-10-10T17:51:43Z] <Amir1> add "Ladsgroup" to oversight members in enwiki in beta cluster to test T177705

I tested in beta cluster and it works just fine, The problem is that I'm not an oversighter in any production wikis (I might request in fawiki soon, but that's not relevant) it's hard for me to check and see what's going on. One hypotheses is that the javascript gets broken due to caching and loading the old javascript snippet for Special:Block, so a hard refresh might fix it.

Special:Block is now using OOUI again on group 0 & 1 (that is everything exept most -pedias). Could you have a look whether this works again now (preferably before this goes out to group 2 tomorrow)?

Special:Block is now using OOUI again on group 0 & 1 (that is everything exept most -pedias). Could you have a look whether this works again now (preferably before this goes out to group 2 tomorrow)?

@MarcoAurelio, Can you test it? I'd really appreciate it, also please remember to clear the cache (ctrl+shift+r)

Sure, I can test. I'll check a random group 0/1 wiki and will report back to you. Stay tuned :-)

Tested. The suppress option only appears if you select an 'infinite' expiry time (which is okay as temporary hideuser blocks make no sense). Behaviour of the blocking hasn't changed apparently so I'd say it now works :)

EddieGP closed this task as Resolved.Oct 12 2017, 8:43 PM
EddieGP claimed this task.

Tested. The suppress option only appears if you select an 'infinite' expiry time (which is okay as temporary hideuser blocks make no sense).

Indeed, that's a feature. I've implemented it back in T133036 to explicitly work this way.

Behaviour of the blocking hasn't changed apparently so I'd say it now works :)

Nice :) Setting "resolved" here accordingly.

I think there has never been a bug here. I remember specifically testing this when working on the patch and it worked correctly. Now we've done exactly nothing to resolve this and it magically fixes itself?

I think this has just always worked correctly (the option was there). But, as you noted, it disappears unless 'infinite' expiry time is selected (this is not a new feature, it worked like this before), so it was easy to get confused, especially with prior cases of similar bugs on other pages.

Change 383008 abandoned by Bartosz Dziewoński:
Revert "SpecialBlock: Tweaks for OOUI HTMLForm"

Reason:
Not necessary.

https://gerrit.wikimedia.org/r/383008

Change 383009 abandoned by Bartosz Dziewoński:
Revert "SpecialBlock: Switch to OOUI form"

Reason:
Not necessary.

https://gerrit.wikimedia.org/r/383009