Page MenuHomePhabricator

CX2: Investigate regressions in the translation editor
Closed, ResolvedPublic

Description

CX2 has experienced several regressions that left it mostly unusable in the current state. We need to investigate which are the causes of these regressions that prevent the editor from doing the basic operations that initially supported (saving, restoring, keeping the alignment, publishing, etc.).

This ticket is about identifying the issues. Supporting these functions to work again is part of separate tickets:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 19 2018, 9:11 AM
Pginer-WMF triaged this task as High priority.Feb 19 2018, 9:11 AM
Pginer-WMF moved this task from Backlog to Priority backlog on the Language-2018-Jan-Mar board.
santhosh claimed this task.Feb 19 2018, 9:12 AM
santhosh moved this task from Priority backlog to In Progress on the Language-2018-Jan-Mar board.

Change 412684 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] Fix: Parsoid section removal and CX section unwrapping in single parsing

https://gerrit.wikimedia.org/r/412684

Change 412686 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] WIP: Support translation units that are already section wrapped

https://gerrit.wikimedia.org/r/412686

Change 413099 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Update section alignment to work with latest VE changes

https://gerrit.wikimedia.org/r/413099

Change 412684 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Fix: Parsoid section removal and CX section unwrapping in single parsing

https://gerrit.wikimedia.org/r/412684

Change 412686 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Support translation units that are already section wrapped

https://gerrit.wikimedia.org/r/412686

Change 413099 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Update section alignment to work with latest VE changes

https://gerrit.wikimedia.org/r/413099

@santhosh - the issues below are addressed somewhere else or they are part of other fixes in in progress?
Loading any article to ContentTranslation page gives numerous Console errors.

Example 1:
http://cx2-testing.wmflabs.org/index.php?title=Special:ContentTranslation&page=Lassie%20Lou%20Ahern&from=en&to=ru&targettitle=Lassie%20Lou%20Ahern

[CX] Node is not under a section: LINK after section mwATo. Ignoring.

Example 2:
http://cx2-testing.wmflabs.org/index.php?title=Special:ContentTranslation&page=Canada%20at%20the%20Winter%20Olympics&from=en&to=es&targettitle=Canada%20at%20the%20Winter%20Olympics

[CX] Node is not under a section: META after section mwIA. Ignoring.

Also, in this case, there are warning-like Console messages:

VM742:27 [CX] Unable to get cxserver token (ignored). 
{error: {…}}
error:
*:"See http://cx2-testing.wmflabs.org/api.php for API usage. Subscribe to the mediawiki-api-announce mailing list at <https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce> for notice of API deprecations and breaking changes."
code
:"token-impossible"
info:"JWT is not installed."
__proto__:Object
__proto__:Object

Change 412846 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] Wrap the template fragments in a single section

https://gerrit.wikimedia.org/r/412846

Petar.petkovic moved this task from QA to In Review on the Language-2018-Jan-Mar board.
Petar.petkovic added a subscriber: Petar.petkovic.

Moving this back to "In review" column, because there is unreviewed patch for this ticket.

Change 412846 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Wrap the template fragments in a single section

https://gerrit.wikimedia.org/r/412846

Change 415262 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] Section wrapping: avoid wrapping figcaptions and dl

https://gerrit.wikimedia.org/r/415262

Change 415262 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Section wrapping: avoid wrapping figcaptions and dl

https://gerrit.wikimedia.org/r/415262

Change 416915 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] CX2: Page loading corrections

https://gerrit.wikimedia.org/r/416915

Change 416915 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] CX2: Page loading corrections

https://gerrit.wikimedia.org/r/416915

Pginer-WMF closed this task as Resolved.Mar 19 2018, 8:12 AM