Page MenuHomePhabricator

CX2: Integrate auto save with VE content changes
Closed, ResolvedPublic

Description

We need to rewire the autosave mechanism with the visual editors transaction events based on the CX-VE integration architecture

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterAutosave: On section content change, save the content

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 25 2017, 11:31 AM

In https://gerrit.wikimedia.org/r/#/c/379213/, basic autosave support implemented.
It connects the update events for the section nodes to the translation update events and do autosave. Section HTML content is extracted from the source and target
models. Some refactoring and utility method additions done for that.

Many sections throw errors while extracting content, for example sections with references. That need investigation and follow up fixes.

Success:


Failure:

Change 379213 had a related patch set uploaded (by Catrope; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Autosave: On section content change, save the content.

https://gerrit.wikimedia.org/r/379213

Change 379213 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Autosave: On section content change, save the content

https://gerrit.wikimedia.org/r/379213

Arrbee moved this task from Backlog to QA on the Language-2017-July-Sept board.Sep 26 2017, 7:03 AM
Arrbee added a subscriber: Arrbee.Sep 28 2017, 6:36 AM

Auto-saving has been confirmed. After the patch for restoration [T176843] of a saved translation is merged, the complete workflow will need to be retested for a final confirmation.

Many sections throw errors while extracting content, for example sections with references. That need investigation and follow up fixes.

This is fixed in https://gerrit.wikimedia.org/r/379213 itself

Arrbee moved this task from Backlog to QA on the Language-2017-Oct-Dec board.Oct 4 2017, 3:15 PM
Amire80 moved this task from Needs Triage to CX2 on the ContentTranslation board.Oct 27 2017, 5:20 AM

Checked in http://cx2-testing.wmflabs.org/index.php?
It correctly counts the time and displays it to a user: e.g. "Saved just now", "Saved 16 minutes ago".

Etonkovidova closed this task as Resolved.Nov 9 2017, 7:05 PM
Nikerabbit moved this task from QA to Done on the Language-2017-Oct-Dec board.
Pginer-WMF reopened this task as Open.Feb 16 2018, 7:35 AM
Pginer-WMF added a subscriber: Pginer-WMF.

There seems to be a regression. Autosave does not seem to work on CX2 right now. We may wat to investigate and fix.

Pginer-WMF triaged this task as High priority.Feb 16 2018, 7:36 AM
Pginer-WMF moved this task from Backlog to Priority backlog on the Language-2018-Jan-Mar board.
Pginer-WMF closed this task as Resolved.Mar 19 2018, 8:18 AM
Pginer-WMF moved this task from Priority backlog to Done on the Language-2018-Jan-Mar board.