Page MenuHomePhabricator

The page field in Special:Abusefilter/test and Special:Abuselog has become mandatory
Closed, ResolvedPublic

Description

After today's train I noticed that the "page" field on Special:Abusefilter has become mandatory. This means that users can't test filters the way they want, but instead they have to add a page, which sometimes could make testing unuseful. This bug does not come from AbuseFilter, since on my local wiki using the master I don't have it. Instead, it's more likely to come from either OOUI or HTMLForm. Further investigation coming.

Event Timeline

Daimona created this task.May 10 2018, 8:08 PM
Restricted Application added subscribers: OldUser02, Aklapper. · View Herald TranscriptMay 10 2018, 8:09 PM
Daimona triaged this task as High priority.May 10 2018, 8:09 PM
Daimona claimed this task.May 10 2018, 8:14 PM

Woah, the default has been changed in HTMLForm. Glad to know that it was meant to unbreak core widgets, but it broke ours. I'll send a patch shortly, which we should also backport.

Daimona raised the priority of this task from High to Unbreak Now!.May 10 2018, 8:15 PM

This also makes AbuseLog unusable, unless of course you're looking for a specific page.

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptMay 10 2018, 8:16 PM

Change 432518 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Explicitly declare title fields as optional

https://gerrit.wikimedia.org/r/432518

Change 432519 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@wmf/1.32.0-wmf.3] Explicitly declare title fields as optional

https://gerrit.wikimedia.org/r/432519

Change 432518 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Explicitly declare title fields as optional

https://gerrit.wikimedia.org/r/432518

Xiplus added a subscriber: Xiplus.May 11 2018, 2:12 PM

Do we want to SWAT deploy on Monday? Otherwise we should probably lower this to High priority.

Huji added a subscriber: Huji.May 14 2018, 12:35 AM

Yes I would like https://gerrit.wikimedia.org/r/#/c/432519/ to be deployed on Monday.

MusikAnimal added a comment.EditedMay 14 2018, 12:54 AM

Okee doke! Are either of you familiar with the SWAT process? We need to schedule the change for deployment at https://wikitech.wikimedia.org/wiki/Deployments#Week_of_May_14th, and be on IRC at #wikimedia-operations during that time. You'll probably be asked to check the debug server before the changes are synced. I'm confident enough in that patch to serve as the deployer or responsible developer but I won't be able to do it until the evening SWAT window at 23:00 UTC.

Yes, I'd also like to deploy today. However, I won't be available in any of today's slot. So, feel free to pick it yourself, otherwise I hope to get it for SWAT for tomorrow :-)

Daimona added a subscriber: Xaosflux.

The issue is known, it's not caused by AF and is already fixed in the master. It wasn't deployed due to Echo test fails which are blocking patches on past branches. Unfortunately, unless those issues are fixed, we'll have to wait for the next train.

Xaosflux renamed this task from The page field in Special:Abusefilter/test has become mandatory to The page field in Special:Abusefilter/test and Special:Abuselog has become mandatory.May 15 2018, 3:44 PM

Change 432519 abandoned by Huji:
Explicitly declare title fields as optional

Reason:
Can wait for the train

https://gerrit.wikimedia.org/r/432519

MusikAnimal lowered the priority of this task from Unbreak Now! to High.May 15 2018, 10:41 PM

Lowering from UBN since we're waiting for the train

Daimona closed this task as Resolved.May 22 2018, 7:54 PM
Vvjjkkii renamed this task from The page field in Special:Abusefilter/test and Special:Abuselog has become mandatory to m6caaaaaaa.Jul 1 2018, 1:10 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Daimona as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: Huji, gerritbot, Aklapper.
Daimona renamed this task from m6caaaaaaa to The page field in Special:Abusefilter/test and Special:Abuselog has become mandatory.Jul 1 2018, 10:18 AM
Daimona closed this task as Resolved.
Daimona claimed this task.
Daimona updated the task description. (Show Details)
Daimona added subscribers: Huji, gerritbot, Aklapper.