Page MenuHomePhabricator

CX2: Uncaught TypeError: Cannot read property 'element' of null
Closed, ResolvedPublic

Description

  • Article: Mumbai
  • Language Pair: en -> hi
  • MT: Yandex

Error seen:

Uncaught TypeError: Cannot read property 'element' of null
    at VeCeMWTransclusionInlineNode.ve.ce.View.initialize (ve.ce.View.js?9c8a2:109)
    at VeCeMWTransclusionInlineNode.ve.ce.LeafNode.initialize (ve.ce.LeafNode.js?2240c:45)
    at VeCeMWTransclusionInlineNode.ve.ce.GeneratedContentNode.render (ve.ce.GeneratedContentNode.js?872c3:210)
    at VeCeMWTransclusionInlineNode.ve.ce.MWTransclusionNode.render (ve.ce.MWTransclusionNode.js?22ebc:180)
    at VeCeMWTransclusionInlineNode.ve.ce.GeneratedContentNode.doneGenerating (ve.ce.GeneratedContentNode.js?872c3:344)
    at ve.ce.GeneratedContentNode.js?872c3:281
    at fire (load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=15h9e2m:3317)
    at Object.fireWith [as resolveWith] (load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=15h9e2m:3447)
    at Object.deferred.(/core/anonymous function) [as resolve] (http://localhost/core/load.php?debug=true&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=15h9e2m:3778:36)
    at VeCeMWTransclusionInlineNode.ve.ce.MWTransclusionNode.onParseSuccess (ve.ce.MWTransclusionNode.js?22ebc:168)

Steps to reproduce:

  1. Start an article with given title and language pair.
  2. Save article.
  3. Go back to Dashboard.
  4. Open saved article.
  5. Scroll till last saved paragraph.
  6. Click next paragraph.
  7. Above error will happen. No user visible changes.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 21 2018, 8:24 AM

This is happening after clicking on paragraph. Article was loaded from Saved article.

Arrbee updated the task description. (Show Details)Jun 21 2018, 8:52 AM
KartikMistry updated the task description. (Show Details)Jun 21 2018, 8:55 AM
Pginer-WMF triaged this task as Medium priority.Jun 25 2018, 10:42 AM
Arrbee moved this task from Needs Triage to CX2 on the ContentTranslation board.Jun 25 2018, 10:48 AM
Vvjjkkii renamed this task from CX2: Uncaught TypeError: Cannot read property 'element' of null to mjaaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii raised the priority of this task from Medium to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from mjaaaaaaaa to CX2: Uncaught TypeError: Cannot read property 'element' of null.Jul 2 2018, 9:25 AM
CommunityTechBot lowered the priority of this task from High to Medium.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.

Same exception as T198826, so we should check if the fix there fixes this (it might not, the error was much further up the stack).

It seems T198826 is merged and deployed. We should check this again if that's fixing this issue?

Now I'm getting POST https://cxserver.wikimedia.org/v2/translate/en/hi/Yandex 500 () for any paragraph. @Petar.petkovic Is this already reported?

Now I'm getting POST https://cxserver.wikimedia.org/v2/translate/en/hi/Yandex 500 () for any paragraph. @Petar.petkovic Is this already reported?

I don't think that is reported. On which wiki did you try? On cx2-testing, I get 403 Forbidden because of Authorization header is not valid: JsonWebTokenError: secret or public key must be provided, for every paragraph, after which Yandex gracefully falls back to source text.

I don't think that is reported. On which wiki did you try? On cx2-testing, I get 403 Forbidden because of Authorization header is not valid: JsonWebTokenError: secret or public key must be provided, for every paragraph, after which Yandex gracefully falls back to source text.

I checked on Production. Yandex doesn't work on cx2-testing (or Labs instance). So, we need to test either locally or on Production for Yandex.

I can't reproduce this no longer (Both original issue and Yandex issues). So, this is unblocked and can be closed.

Arrbee closed this task as Resolved.Jul 26 2018, 9:01 AM
Arrbee claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 26 2018, 9:01 AM
Arrbee removed Arrbee as the assignee of this task.Jul 26 2018, 9:01 AM
Arrbee added a subscriber: Arrbee.