Page MenuHomePhabricator

All "zh-my" variant page views get 404 Not Found on zh.wikipedia.org
Closed, ResolvedPublic

Description

The zh-my language variant is incorrectly configured. Error 404 happens when I try to use the localization.

This problem when I type in this url, for example:

https://zh.wikipedia.org/zh-my/Wikipedia:首页


Split from https://phabricator.wikimedia.org/T193983#4315557

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptJun 28 2018, 4:53 AM
RazeSoldier added a comment.EditedJun 28 2018, 7:03 AM

This may be because the corresponding URL rewrite rule is not set.

Aklapper renamed this task from zh-my localization not correctly setup. Error 404 page found to "Error 404 page found" for zh-my localized URLs on zh.wikipedia.org.Jun 28 2018, 7:30 AM
Aklapper updated the task description. (Show Details)

@1233thehongkonger: For future tasks, please add a more complete description to this report and always include a clear list of specific steps to reproduce the situation, describing actual results and expected results after performing the steps to reproduce.
You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results.
Please also remove unneeded project tags from tasks. Thanks!

1233thehongkonger renamed this task from "Error 404 page found" for zh-my localized URLs on zh.wikipedia.org to "Error 404 page not found" for zh-my localized URLs on zh.wikipedia.org.Jun 28 2018, 11:05 AM

@1233thehongkonger: For future tasks, please add a more complete description to this report and always include a clear list of specific steps to reproduce the situation, describing actual results and expected results after performing the steps to reproduce.
You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results.
Please also remove unneeded project tags from tasks. Thanks!

This is the problem of split lol.

Have added the steps to reproduce now

Looks related to the site configuration.

I add this tag, because this task is related to modifying the apache config file in puppet repo.

Change 443215 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/puppet@production] Support zh-my localized URLs

https://gerrit.wikimedia.org/r/443215

Urbanecm claimed this task.Jun 30 2018, 1:37 PM
Urbanecm triaged this task as Normal priority.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptJun 30 2018, 1:37 PM
RazeSoldier added a comment.EditedJun 30 2018, 1:51 PM

Change 443215 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/puppet@production] Support zh-my localized URLs
https://gerrit.wikimedia.org/r/443215

I heard that only Ops can push puppet patch.

Everyone can propose a patch to any repository, only repository owners (also known as +2 right) can approve it. It can be that only ops are repository owner of puppet repo, I don't know.

Krinkle renamed this task from "Error 404 page not found" for zh-my localized URLs on zh.wikipedia.org to All "zh-my" variant page views get 404 Not Found on zh.wikipedia.org.Jul 9 2018, 11:52 PM
Krinkle raised the priority of this task from Normal to High.
Krinkle updated the task description. (Show Details)
Krinkle added a project: Operations.
hashar removed a subscriber: hashar.Jul 10 2018, 9:43 PM

Should be deployment problem?

@RazeSoldier , should be problem within the Operations tem?

@RazeSoldier , should be problem within the Operations tem?

The assignee has not yet scheduled the patch in the calendar. When to deploy the patch depends on Urbanecm.

Well, all puppet patches I ever pushed to Gerrit were deployed by @Dzahn after I added him as reviewer. If I should do something else (for example schedule for Puppet SWAT), please let me know.

Change 443215 merged by Filippo Giunchedi:
[operations/puppet@production] Support zh-my localized URLs in Wikipedia virtualhost

https://gerrit.wikimedia.org/r/443215

I am very happy to see that this problem has been solved.

Shizhao closed this task as Resolved.Jul 27 2018, 3:55 AM